Search:

Type: Posts; User: Hardluck29

Search: Search took 0.00 seconds.

  1. Replies
    16
    Views
    6,200

    This is a really old thread but did his timing...

    This is a really old thread but did his timing Drop Problem ever get solved? I have the same problem but all my torque management is disabled. Or so I thought.
  2. Replies
    0
    Views
    58

    L94 Pulling Timing as Load Increases

    Can someone tell me if this looks normal. When I increase the throttle and the load increases the timing will drop from 28 deg to about -8 degrees. When I installed the VVT the spring came out. ...
  3. Thanks for the Reply and any advice you have for me

    Hey Thanks for the Reply. I ran it for a bit tonight and it could be my imagination but it seemed to be getting better. You'll see three revs at the end of the attached log and I got no bounce at...
  4. Engine Revs again after returning to an Idle.

    I have a 2010 Escalade Engine with a Cam Swap. 235/247, .649"/.629", 113 LSA . The issue I'm having is if I rev the engine in neutral then let off the pedal it will return to idle but then rev...
  5. Update for anyone who is reading. Put the...

    Update for anyone who is reading. Put the correct injector information in the PCM to matching the injectors from a 2010 Escalade and things are much better.
  6. Yeah I see that... the 2010 Gen IV Engines have...

    Yeah I see that... the 2010 Gen IV Engines have much larger injectors. I'm going to try to load the injector information for a 2010 Escalade. Thanks for the confirmation.
  7. Update I got an updated Tune for my Tuner and it...

    Update I got an updated Tune for my Tuner and it looks very similar to the big cam idle tutorial on the HPT website. However still won't idle. I've double checked all wiring, compression is good...
  8. FYI got a call from Casey tonight. I'll post...

    FYI got a call from Casey tonight. I'll post again with an update.
  9. Gen IV L94 with TSP VVT4.2 CAM Won't IDLE

    Hey everyone-

    I have an L94 with the TSP 4.2 VVT Cam Kit installed. The problem is I can't get it to idle on its own without holding the pedal at about 1200 rpm and even then it surges. I've...
Results 1 to 9 of 9