But of a weird one, had this car a while FG ZF 6 speed auto been faultless since Ive owned it

Last week coilpack died out of nowhere while driving
Tried another set and didn't fix the issue, seemed to have low spark on cylinder 1,3,5 so pulled the pcm to check wiring and earth's, all was good no shorts ect, still wasn't running on all cylinders, cleaned fuses, charged battery again ect. Double checked wiring
So tried some know B series coilpacks with a adaptor harness they worked fine, tried FG coils again and they worked fine🤔

Went for a drive this morning flashed a change to the tune and drove fine, give it a thrashing all was good

Come out this afternoon to load a change to the tune on again and straight away failed to write, erased the tune and come up with a invalid checksum error or something, tried flashing it multiple times without success, tried reading the file and it had deleted the VIN number and only reads the ZF TCM

Connected VCM scanner and get a constant PCM disconnected from TCM code (usually get that when not writing to the TCM) and clears straight away

There is no VIN number or year model for the ECU when scanner is connected

Have flashed this car hundreds of times being the daily without issue

I am using a generic USB-C cable (meant to be a high speed data cable) the cable is lucky to be 2 weeks old as HP tuners one got broken very easily with a small bump