Results 1 to 10 of 10

Thread: WOT AFR changes on its own!!!

  1. #1

    WOT AFR changes on its own!!!

    Hello everyone, i?m facing a weird issue were the AFR at WOT changes without any changes in the tune or parts. Let?s say i changed the tune today and it?s running 12.4 AFR per the car?s wideband in the VCM Scanner, after couple of days or a week or how ever much time it wouldn?t read anywhere near the 12.4 it was set too it would be either much leaner or much richer than what it should it could be over 13.0 or under 11.4 around 1 number higher or lower.
    What could be the cause of that ?

    Any suggestions is welcome.
    Thanks in advance i hope someone can help.

  2. #2
    Any idea or list of possible solutions is truly appreciated.

  3. #3
    Tuner in Training
    Join Date
    Jun 2015
    Location
    Melbourne, Australia
    Posts
    31
    Without knowing what car you're working with, I have found on some makes and models that LTFT from normal driving can get locked in and carry through a WOT pull. For example, I've had cars with spot on AFR's on the dyno (because the LTFT would reset with each flash), then do road tuning for the low load and drivability stuff, and it will pick up a correction in the background and leave it there. If it was averaging say -5% LTFT, it would lock it in and pull 5% everywhere, even under WOT. You should be able to log all this though to isolate whether that is the issue or if you have a hard problem with the car itself.

  4. #4
    The car is a 2020 370z. The ltft goes back to 0 when on WOT and the issue also happens on the stock tune a well so it’s not necessarily a tunning issue. Isn’t maf sensors and O2 sensors supposed to be adjusting for weather while keeping on the same AFR ?
    I was thinking more of a fueling issue like fuel pump or fuel pressure or even fuel pulsation damper which I don’t even know what it does.

  5. #5
    One more thing also, lately i had an issue were the engine oil was getting increased significantly by fuel dilution. And there also was no ltft or stft issues. Checked engine compression and it was good and there were no leaks or excessive fuel usage or drop in the fuel economy. Lately the problem seems to be gone or got a lot better but could it be related to my original issue?

  6. #6
    Advanced Tuner 04silverado6.0's Avatar
    Join Date
    Sep 2021
    Location
    Kentucky
    Posts
    717
    You got a file? Datalog? Will these cars log fuel pressure? Misfire? Exhaust leak?

  7. #7
    Advanced Tuner 04silverado6.0's Avatar
    Join Date
    Sep 2021
    Location
    Kentucky
    Posts
    717
    Fuel trim imbalance bank to bank?

  8. #8
    Quote Originally Posted by 04silverado6.0 View Post
    You got a file? Datalog? Will these cars log fuel pressure? Misfire? Exhaust leak?
    I’ll share both my stock file and data log for stock and tuned. No fuel pressure or misfire is available for data logging. No exhaust leaks.

  9. #9
    Quote Originally Posted by 04silverado6.0 View Post
    Fuel trim imbalance bank to bank?
    There is slight imbalance bank to bank in the ltft but not a lot and depending on the load and rpm sometimes they are exactly the same bank to bank and some times around 3-5 percent difference.
    At WOT there nearly no difference bank to bank in the AFR

  10. #10
    Stock Tune.hptStock Tune March.hplStock Tune July.hpl

    Here is my stock tune with two log runs, one is in March and the other is in July with the same Tune same Parts there is a huge difference in AFR at WOT.
    What I'm after is the cause of this huge difference.