Page 12 of 12 FirstFirst ... 289101112
Results 221 to 240 of 240

Thread: Gen4 idle tuning guide

  1. #221
    Advanced Tuner
    Join Date
    Jun 2007
    Location
    Finland, Europe
    Posts
    407
    Quote Originally Posted by Hib Halverson View Post
    Still scratchin' my head on this one.
    In your log - beginning of it - you have a fueling issue. Add IVT into your log and check how much it is changing when idle is oscillating. Then modify IVT gain table accordingly.

  2. #222
    Tuner
    Join Date
    Mar 2010
    Location
    Goleta CA
    Posts
    91
    Quote Originally Posted by Pekka_Perkeles View Post
    In your log - beginning of it - you have a fueling issue. Add IVT into your log and check how much it is changing when idle is oscillating. Then modify IVT gain table accordingly.
    The beginning of that log is just as right after the engine was started, so I sort of discount the very first part of the log as useable data, but I will log IVT going forward.
    Hib Halverson
    Just Another Tuner in Training.

  3. #223
    Tuner
    Join Date
    Mar 2010
    Location
    Goleta CA
    Posts
    91
    More research shows this "quirk" is wrote about on the OP is just the way it is. I flashed the PCM with other cal files, two of them stock, and could see the same thing, regardless.

    So I re-evaluated some idle stuff I'd done. I decided I'd relaxed the adaptive spark a little too much so I want back the other way a bit. I, also, did some further tweaking of the integral idle table.
    (sigh)
    Life is better now.
    Hib Halverson
    Just Another Tuner in Training.

  4. #224
    Potential Tuner
    Join Date
    Jun 2019
    Posts
    1
    Hi there Mike,enjoyed reading your great sticky on gen 4 idle tuning.....Are you still in the game?? Maybe you could consider doing a similar sticky on drive by wire gen111 pcm......my 2001 c5 m6 ls7 has a very good tune in it.......but it needs attention in the idle derivatives/proportional and base minimum airflow. Also need to get the area scalar set for the 90 mm throttle body. Have efi live, and if the procedures are clear, I will get there..... after many years of these idle issues...it will great to resolve them. If you need me to post my tune,can do, many thanks Mike Regards Frog.

  5. #225
    Tuner in Training
    Join Date
    Mar 2016
    Posts
    12
    your gen 3 are super easy to tune idle
    theres actually a set of maths floating around and the tables and everything
    its called russk idle tuning

  6. #226
    Tuner in Training
    Join Date
    Mar 2016
    Posts
    12
    Hi Guys,
    I have a 07 Ls2 C6 Corvette that I am tunning VVE Tables now, I am tuning with the fuel trims turned off and using AFR err
    However I notice the STFT for Idles is -20%
    Is this because of cam overlap or is this just to much air added in the idle airflow table
    Attached Files Attached Files

  7. #227
    Potential Tuner
    Join Date
    Jul 2019
    Posts
    2
    Hello guys,

    So I am very new to this tuning thing. I have really enjoyed reading this thread and I am learning a lot from everyone.
    I currently am having an idle problem directly after start up. Once I start the truck it oscillates from about 400 rpm to 1100 rpm back and forth for about a min. this is during a cold start. aafter that min the truck calms down and idles right about 600 just fine. I can drive it all day and its been idling great. the issue is when I start it in the morning or after I get off work. I have no idea what to adjust in the tune to solve this issue. I feel like I have messed with everything involved with idle just to get it to do something different.


    Truck:
    2008 GMC Sierra 1500
    5.3L non-DOD
    E-38 ecm
    LS9 cam upgrade
    243 heads
    flat top pistons
    kooks long tubes/y pipe with cats

  8. #228
    Sounds like you need to add to startup airflow as a first guess. Add about 5% a day to that table and see if it improves over a few mornings. Or copy an ls9 or ls3 table and likely work down from there.

  9. #229
    Potential Tuner
    Join Date
    Jul 2019
    Posts
    2
    awesome thank u so much for the help I will give that a shot during this week

  10. #230
    I just re-read your original post- you likely need to add to base running airflow as well if it lasts for more than initial startup, or if it has hunting issues when you come to a stop. Since it's a GM cam, the stock over/under spark tables should play fine with it. Likely just airflow and base spark to get it in line.

  11. #231
    Potential Tuner
    Join Date
    Jan 2019
    Posts
    3
    Thanks BigMike42
    I'm going to try this on my LS376/480.

  12. #232
    Potential Tuner
    Join Date
    Mar 2017
    Posts
    3
    subscribed, definitely need the assistance

  13. #233
    Head is spinning. Tons of hours invested learning and tweaking slowly. Have pretty good results so far.. 5.3L Gen IV, No cats, K&N rest is stock. First issue, Starts and idles decent at warm ambient temp. About 1:40 into idle test, the advance just jumps from 16 to 25 and stays there! I've looked at all kinds of things trying to find what causes this. It seems like it's related to ECT maybe. At or about 127deg.F it takes this jump but I can't find the table that is doing it. Can someone take a look at my tune and scan and offer advice?

    Thanks!
    Idle test on 8-20-19.hpl
    Jeep idle tweak1_ EOIT lower_makeup EOI lower_add stock ect spark correction_shorten O2 ready de.hpt
    Last edited by markeheiden; 4 Weeks Ago at 10:49 PM.

  14. #234
    Senior Tuner
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    1,100
    Quote Originally Posted by markeheiden View Post
    Head is spinning. Tons of hours invested learning and tweaking slowly. Have pretty good results so far.. 5.3L Gen IV, No cats, K&N rest is stock. First issue, Starts and idles decent at warm ambient temp. About 1:40 into idle test, the advance just jumps from 16 to 25 and stays there! I've looked at all kinds of things trying to find what causes this. It seems like it's related to ECT maybe. At or about 127deg.F it takes this jump but I can't find the table that is doing it. Can someone take a look at my tune and scan and offer advice?

    Thanks!
    u are asking for 25 deg in the idle and main spark tables so it may be held down by something till it warms up, u will be able to see more if u log more pids, dynamic air, cylinder air, bank 1 and 2 inj PW, idle adaptive advance, those will help see what its trying to do, there is also alot of those other tables changing spark like cat heating, piston slap ect

  15. #235
    Can I turn off or zero out all the tables for cat heating (Light off spark) since I have no cats? Also, why does an "idle spark" table have the whole rpm range. The idle is the idle and it's never high rpm?
    Last edited by markeheiden; 4 Weeks Ago at 10:22 AM.

  16. #236
    Senior Tuner
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    1,100
    u can zero out those tables ive done that in mine since i dont need to use them, i think the idle table may be like that to smooth transitions from the coastdown maby, the idle table can be used for alot of the off throttle control depending on how u have it all setup but yea still wouldnt need the full range, if u set your main spark to a bit higher like 35 so its different to your idle then at idle very slowly push the throttle down and u will see the point it changes to the main spark table then u can see what adjustment area u have in the idle table, it can also be good to have the main spark higher then idle by at least 10 deg as it can act as a limit to the idle spark corrections in some OS

  17. #237
    Thanks! I zero'd all the cat heating and lowered the base idle spark table in the 800 and below area, left the bas spark table alone since it technically says "open throttle" which is not idle.. It now starts and goes instantly to 1,100 rpm then instantly drops to about 450rpm then smooths out to the commanded 750 and idles smooth as silk. Even when the STFT and LTFT kick in they are all nice low numbers. Only two issues now. That initial drop to 450rpm and some minor fuel smell at idle. Have tweaked startup flare control and overspeed and underspeed tables but can't tell which one affects that initial few seconds. Will try to play with EOIT and little more to minimize the smell.

  18. #238
    Senior Tuner
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    1,100
    your throttle follower torque for neutral/park is low u could raise that see if it helps with the dip, or even the integral airflow limits ecm12199 change your high "normal" limit -6 to a 6 see if that helps

  19. #239
    I don't see any of that in the tune I posted. My follower tables are all stock. The ecm 12199 looks like this:

    Low limit normal -47.620
    Low limit coastdown -47.620
    High limit normal -47.620
    High limit coastdown 79.366

  20. #240
    Senior Tuner
    Join Date
    Jan 2014
    Location
    Australia
    Posts
    1,100
    Quote Originally Posted by markeheiden View Post
    I don't see any of that in the tune I posted. My follower tables are all stock. The ecm 12199 looks like this:

    Low limit normal -47.620
    Low limit coastdown -47.620
    High limit normal -47.620
    High limit coastdown 79.366
    ok yea im looking at it in g/s so my numbers will be smaller, your normal high limit is a negative number but high coastdown is positive for the same error which is how they come stock but u can see if it helps making the high normal a positive limit see if it helps, throttle follower torque ecm12123 if u have done mods u can look at raising that neutral/park ?