Results 1 to 17 of 17

Thread: Getting Error P167F

  1. #1
    Tuner in Training
    Join Date
    Feb 2015
    Posts
    22

    Getting Error P167F

    I'm getting this Error code P167F "Non-OEM programming detected.", the truck is a 2016 Heavy Duty 6.7L

    the truck runs great for 10-15min and suddenly I get the error and the truck goes into a protected mode. what should I do in order to avoid this error

    thanks in advance

  2. #2
    Advanced Tuner RandomEnthusiast's Avatar
    Join Date
    Feb 2016
    Location
    Texas
    Posts
    351
    That's an interesting one. I think another module is playing baby sitter for ford. Most flashes don't have thus issue. I can't find to much info on it specifically.

  3. #3
    Senior Tuner
    Join Date
    Feb 2006
    Location
    South Carolina
    Posts
    1,530
    Can you disable it in the DTC list?

  4. #4
    Tuner in Training
    Join Date
    Feb 2015
    Posts
    22
    Yeah, I did try that. I don't get the check engine light now but the protected mode is still happening.

    and if I go back to stock everything is normal again

  5. #5
    HPT Employee Engineer@HPT's Avatar
    Join Date
    Jan 2015
    Location
    fecadefa
    Posts
    615
    Please e-mail support and reference this thread.

  6. #6
    Potential Tuner
    Join Date
    Aug 2016
    Posts
    6
    Have you turned the code off in the dtc list?
    Mitch Edwards
    President
    AM Diesel Performance Inc.
    www.amdieselperformance.ca
    Canada
    250.634.0196

  7. #7
    Tuner in Training
    Join Date
    Dec 2015
    Posts
    40
    Just checking to see if this ever got resolved, I have a friend with a 16 that wants to try some programing.

    Thanks

  8. #8
    HPT Employee Engineer@HPT's Avatar
    Join Date
    Jan 2015
    Location
    fecadefa
    Posts
    615
    I have not gotten a ticket related to this issue yet.

  9. #9
    Tuner in Training
    Join Date
    May 2017
    Posts
    15
    Hello, I dropped an email to support to see if you have anything on this.

    I'm having this pop up as well for a Very minor adjustment and correcting the speedo only.

    What triggers this one? Someone is babysitting us lol.

    Does this show up in an OBDII emissions scan as disabled?

    There is like Nothing useful that comes up in searches for this that I have found so far.

    Thx.

  10. #10
    Tuner in Training
    Join Date
    Nov 2007
    Location
    Indiana
    Posts
    38
    So, you flash the truck, now a P207F code sets? P207F is a reductant quality code.

  11. #11
    Tuner in Training
    Join Date
    May 2017
    Posts
    15
    Quote Originally Posted by bradearlywine View Post
    So, you flash the truck, now a P207F code sets? P207F is a reductant quality code.
    I'm sorry, as the OP, I have P167F "Non-OEM programming detected" after tune.

  12. #12
    Tuner in Training
    Join Date
    Nov 2007
    Location
    Indiana
    Posts
    38
    Quote Originally Posted by X E Ryder View Post
    I'm sorry, as the OP, I have P167F "Non-OEM programming detected" after tune.
    LOL sorry IDK where I picked up the other code. I spaced it.

  13. #13
    Tuner in Training
    Join Date
    May 2017
    Posts
    15
    Quote Originally Posted by bradearlywine View Post
    LOL sorry IDK where I picked up the other code. I spaced it.
    There are enough to make one's head spin - was good intent tho, thx!

  14. #14
    Tuner in Training
    Join Date
    Apr 2018
    Posts
    23
    2016 f250 Same issue minor changes and p167f DTC thrown. Any update on this?

  15. #15
    Tuner
    Join Date
    Jun 2018
    Location
    Albuquerque New Mexico
    Posts
    84
    Quote Originally Posted by Jwilliams View Post
    2016 f250 Same issue minor changes and p167f DTC thrown. Any update on this?
    Did you change anything related to the tire size or try re-calibrating the speedometer?

  16. #16
    Tuner in Training
    Join Date
    Apr 2018
    Posts
    23
    I changed the speed limiter and added 5% pulse width. That's it.

  17. #17
    Tuner
    Join Date
    Jun 2018
    Location
    Albuquerque New Mexico
    Posts
    84
    Can you Post your tune so i can look at it and see if there's a issue? It might be that you increased it outside of the parameter limits which creates the problem.