Results 1 to 19 of 19

Thread: C63 M156 Superchaged P0607 DTC

  1. #1
    Potential Tuner
    Join Date
    Nov 2011
    Posts
    4

    C63 M156 Superchaged P0607 DTC

    Hello,

    I have Mercedes C63 2012 M156 with Magnusson Supercharger.
    I tuned it and it works ok but sometimes it shows DTC P0607 (ECU Performance Malfunction).
    The car goes to limp mode after this DTC.
    Maybe somebody knows what reasons could be for this DTC.

    It gets it not all the time. It gets it at WOT rather with DSC system ON.


    Thanks to all who cares ))

  2. #2
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Post the tune file. But from what Im reading its pointing towards a wiring or ECU issue. Did you have a different tune on the car before tuning with HP Tuners?

  3. #3
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Same problem herelesha_c63_tune_2_fans.hpt

  4. #4
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    I overwrote the Weistec tune with HPT.

  5. #5
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Max aircharge WOT, Wheel torque vs VSS, disable spark retard for tq management, EGT tq limit, reduce timing a LOT. Start with that stuff.

  6. #6
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    You wont believe...
    It was the Injector multiplier map which I've multipled by 0.8 to compensate for larger injectors.
    Tried without any corrections - worked.
    Tried 0.9 mult - it worked.

    Will try 0.85 tomorrow. Maybe will still work.

    P.S. Guess what - even 100% stock file without single correction worked without limp mode and P0607 code. Car was obsiously jerking and going crazy under medium load when the supercharger starting to make boost but still no limp. Then I tried to lean it out by 20% with Injector multiplier map. And bingo! Limp mode.

  7. #7
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Changing that will likely change the interpreted load amount. Did you compare that before and after changing the injector scaling?

  8. #8
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Haven't compared the load. But the fuel trims do change as should. With 0.9 multiplied injector map the Engine load is about 90% when it starts making boost.

  9. #9
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Now, after dyno tune attempt it seems to randomly pull timing in 3000-5000rpm area.
    All tq management and EGT management is off. No knock, but still pulls timing and then restores.

    c63_dyno.hpl

  10. #10
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Optimum spark tables usually cause that weird dip and then recovery that you are seeing.

  11. #11
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Your fuel trims need some work, and try logging the car using these configuration files. You are missing some important information!

    C63_Tuning.Channels.xml

    c63.Layout.xml

  12. #12
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Need to lower the Optimum spark tables?

  13. #13
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    Raise it in the areas the timing isn't keeping up with your commanded timing. Also, double check the Max Spark Durability table isn't set lower than your commanded timing as well.

  14. #14
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Quote Originally Posted by BackyardTurbo_FTW View Post
    Raise it in the areas the timing isn't keeping up with your commanded timing. Also, double check the Max Spark Durability table isn't set lower than your commanded timing as well.
    OK. It worked. I have adjusted the 2 top load rows in the Max Spark Durability table to the same values as commanded ignition table rows at the same load.

    BTW. If you try to copy paste the whole table - the idle becomes unstable.

    See log and dyno graph attached. No torque reduction, no knock, stable AFR, stable timing. BUT for some reason there is a dip in hp and tq @ 5200rpm.
    I have overlayed the graph to another Weistec stage 3 C63 and the graphs looks very close except this dip. Funny thing that another C63 has the same timing, AFR, cams settings.

    dyno_overlay.jpg
    C63_dyno2.hpl

  15. #15
    Senior Tuner BackyardTurbo_FTW's Avatar
    Join Date
    Jul 2009
    Location
    East Suckburg, PA
    Posts
    1,149
    I would work on the fuel trim a little more and possibly ramp cam timing a little smoother. You can see your cam timing is flat up until 5200 (where the dip is) and then you begin ramping cam timing from there.

  16. #16
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Figured that its transmission related.
    Made another pull in 5th gear and everything fine!

  17. #17
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Tried some road tests after the dyno tune. But...

    When you go light to moderate throttle, sometimes car starts to jerk. It shows Torque limiting active: YES when it jerks.

    To disable these torque related limiters I adjusted the following:
    MAX AIRCHARGE AT WOT: 1536%
    SPARK RETARD TQ MNG
    TQ MNG OFF
    VACUUM LIMIT1 OFF
    VACUUM LIMIT2 OFF
    WHEEL TQ VS VSS 65000
    EGT TQ LIMIT 100
    EGT CONTROL DISABLED

    Do I need to tweak the:

    Indicated Torque Model -> Optimum Torque
    Indicated Torque Model -> Max Ind Tq
    Fuel Effects -> Lambda Efficiency
    Spark Effects -> Ignition Efficiency

    Torque Model -> Monitoring -> Lambda Mult
    Torque Model -> Monitoring -> Spark Mult
    Torque Model -> Monitoring -> Max Indicated

    Throttle -> Max Rotation 100% or 87%?

    Anything to the Engine Diag -> Airflow -> Throttle Position Sensor?
    Engine Diag -> Airflow -> Mass Air Flow Sensor limits?

    Any help would be greatly appreciated. Thanks!

  18. #18
    Tuner in Training
    Join Date
    Aug 2008
    Posts
    30
    Permissible tq from pedal - all table to 99,6%?

  19. #19
    Tuner in Training
    Join Date
    Jun 2018
    Posts
    25
    We had tried majority of what you listed on here a few times but never got the car to run over 20% throttle when in gear. I?m running 630 cc injectors and when scaled ink mult table down by 30%, vehicle idles perfect and not rich but when I put it in gear, the vehicle will go into limo mode once tps is above 20% or so. ECM code will not come on, even when all control modules DTC are disabled, still limped.

    I?m thinking it?s something to do with HP Tuner?