Results 1 to 7 of 7

Thread: 4l80e swap but speed is way off

  1. #1

    4l80e swap but speed is way off

    I did a 4l80e swap and now the scanner and my speedo are showing like half of what i am actually going. but both the scanner and truck match. I also changed rear gear ratio from a 3.42 to 3.73 and i did do the tire/gear wizard but no change. what can i do the solve this issue? bellow is my tune .
    Attached Files Attached Files

  2. #2
    Tuner in Training
    Join Date
    Apr 2009
    Location
    West Plains, Missouri, USA
    Posts
    49
    sounds like you are missing the speed sensor trigger wheel in the rear of the 4l80e. Didn't change a 4wd to a 2wd by chance did you? The speed sensor will pickup the park paw lugs when the 40 tooth trigger wheel is missing. Park paw lugs are about 20-25 of them I think, so about half speed or little faster will be what you get if the trigger is missing.

  3. #3

  4. #4
    I did change from 4wd to 2wd so that is prob the issue. is there a way to way to make it work with only the 1 sensor? or do i have to pull the trans and have it re done with the right part?

  5. #5
    Tuner
    Join Date
    Dec 2018
    Location
    Washington State
    Posts
    107
    Quote Originally Posted by Spoolnsquirrels View Post
    I did change from 4wd to 2wd so that is prob the issue. is there a way to way to make it work with only the 1 sensor? or do i have to pull the trans and have it re done with the right part?
    Unfortunately it has to be pulled.

  6. #6
    Well I can tell you I got it working , since it is sensing the park paw ring I counted the number of lugs. Which is 21, I then entered that number in the speedo section under vss revolution, I then calculated the percentage difference from 40 to 21 which is .525, I then took the Speedo calibration number which mine was 115,289 and multiplied it by .525 and then entered that number into speedo calibration. And it all worked great. It is off on the mph by only 1 mph,

  7. #7
    Quote Originally Posted by DougO View Post
    Unfortunately it has to be pulled.
    Hey DougO where in Washington are you located? I?m in Spokane