Results 1 to 7 of 7

Thread: Trouble getting rid of Deceleration popping 2009 LY5 swap

  1. #1
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    8

    Trouble getting rid of Deceleration popping 2009 LY5 swap

    Hello All,

    I am a a newbie who would appreciate help on turning off deceleration fuel lean on 2009 LY5 swap E38 with VVT delete, LS3 cam and lifters, headers, th350 2500 stall in 1973 Nova. The car runs great through out but I am tired of deceleration popping. I am not concerned about saving mpg and would love to eliminate the popping.

    Thanks Adam
    Attached Files Attached Files

  2. #2
    Tuner in Training
    Join Date
    Nov 2018
    Posts
    37
    Try going back to stock DFCO settings ( or stock LS3 settings) then copy over the DFCO entry and exit spark and blend times from a ZR1 file. That will keep DFCO working (MPGs) and will have zero popping on decel.

    Also, to just disable it, you can just max the enable temp to 493 while keeping everything else stock.

    If you need more help let me know.

  3. #3
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    8
    I reset all my DFCO to LS3 and copied ZR1 entry and exit spark and blend times with no change still popping with 18-20 AFR off throttle. I also set the enable temp to 493 later and still have decel popping so I am starting to think I have something else going on. Thanks for the reply SQUEEGIO! Any help is appreciated

    Thanks Adam

  4. #4
    Tuner in Training
    Join Date
    Nov 2018
    Posts
    37
    Do you have a log of this happening? I believe you can log DFCO activity but that may not be your problem. Are you running an ethanol blend?

    This is your tune with DFCO disabled and MAF only, maybe your VVE is off. Have you tuned VVE or MAF at all?

    1973 nova final tune 2019 DFCO off MAF only.hpt

  5. #5
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    8
    No Ethanol blend, My data log is not reading correctly on AFR. It reads my gen 3 swap fine with the same wide band. I have not tuned MAF or VVE at this point.
    Attached Files Attached Files

  6. #6
    Tuner in Training
    Join Date
    Nov 2018
    Posts
    37
    your stoich table needs to be set up correctly if you're running regular fuel. You also have flex fuel enabled with a virtual sensor so I would disable that. You can use 14.1 in the stoich table if you are using e10 fuel. Your decel lean/popping condition is probably just due to poor fueling via VVE/MAF tables. VVE and MAF need to be tuned properly to get proper fueling. You also have a closed loop fault. Do you have any codes?

    It wouldn't be a bad idea to start over with the stock tune with VVT disabled then go ahead with VVE and MAF tuning separately and see where you are at that point.

    You can do VVE and MAF (no WOT) with fuel trims as long as your O2 sensors are in good working order.

  7. #7
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    8
    Hello guys,
    my fix ended up being 20% fuel added to MAF table which curried my popping and afr issues.

    Thanks Adam