Results 1 to 2 of 2

Thread: 2007 Pontiac Solstice GXP no start

  1. #1

    Unhappy 2007 Pontiac Solstice GXP no start

    This is my personal vehicle and tuning it was the mod i did when i got it. it runs 21 PSI and is stock other than a gutted cat and replacement fuel pump.

    the car was running fine up until April when i started getting engine pwr reduced message but no limp mode or CEL. the car ran fine even with the message on. ran it at the track like that. Around early May it did not want to start and if it did it was sputtering and died. sounded like a bad fuel pump. when it happened i got Low fuel pressure CEL and assumed it must be the HPFP as the symptoms were like bad pump.

    I bought the pump from zzp and installed it today and still have the same issue, except now the only CEL i get is P050a Cold Start Idle Air Control Performance. checked fuel pressure and it is at 58-63 when cranking, there is spark on all coils, and the throttle opens and closes. Another thing that was going on before was that the car was not reading boost anymore. the gauge cluster said 0 even at WOT while feeling the boost kick in. the HPT scanner reads 14.2 on that sensor and does not change when cranking or when it idles. any ideas? i'm posting a log of it cranking. i could not for the life of me get it to idle like the first time i tried to start.

    Edit to add log

    solstice no start after HPFP.hpl
    Last edited by Vasquezz1228; 4 Weeks Ago at 07:15 PM. Reason: added log

  2. #2
    Figured it out I believe. The timing chain is loose. After putting in new spark plugs the car started and ran like normal but with noisy timing chains. Still had low vacuum and decided to take the valve cover off. Loose timing chain seems to be the issue.