Results 1 to 3 of 3

Thread: Is my AEM 30-0300 wiring thru 0411 EGR correct?

  1. #1
    Potential Tuner
    Join Date
    Jul 2017
    Posts
    8

    Is my AEM 30-0300 wiring thru 0411 EGR correct?

    I believe I have this correct, but I'd like some of the more experienced here to verify I've got it right. I have an AEM 30-0300 wideband, I'm taking the brown analog sensor ground from the wideband to the red connector pin 41 EGR ground on the 0411 PCM, and the white analog 0-5 volt from the wideband to the red connector pin 7 EGR +5 volt signal on the 0411 PCM. Is this right?


    AEM 30-0300 serial wiring to 0411.jpg

    Thanks ahead of time!

  2. #2
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    8,171
    Pin 7 won't work because that is not the pintle position sensor signal. Should be pin 55 on the blue connector, that pin will vary the voltage from 0 to 5v. Pin 7 is going to be a constant supply on the red connector.


    Another note, even though my P59 power 2006 truck was not equipped with EGR from the factory because they stopped using it after 2000-2001 in the GM half tons. I was still able to enable it in the calibration because it was an option. Then I still used pin 55 and it worked like a charm.
    Last edited by 5FDP; 3 Weeks Ago at 08:36 PM.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  3. #3
    Potential Tuner
    Join Date
    Jul 2017
    Posts
    8
    Got it. I looked back at how the EGR works and understand now.

    AEM 30-0300 analog wiring thru EGR 0411.jpg

    Thank you!!
    Last edited by AeroSS; 3 Weeks Ago at 05:37 PM.