Results 1 to 3 of 3

Thread: 2007 Pontiac G6 GTP - 3.6L - Transmission Changed To 2008 Help

  1. #1
    Potential Tuner
    Join Date
    Aug 2018
    Location
    Central New York
    Posts
    6

    2007 Pontiac G6 GTP - 3.6L - Transmission Changed To 2008 Help

    Thanks to everyone in advance,

    I have just swapped my transmission on my '07 Pontiac G6 GTP (3.6L, A6) to an '08 and I am having issues:
    1. Speedo is not working.
    2. Manual mode is not working (which I'm not really worried about).

    Here are the OLD SETTINGS:
    TCM OS: 24240291 C714
    ECM OS: 12611134 172A

    Here are the NEW SETTINGS:
    TCM OS is: 24244551 E46C
    ECM OS: (SAME)

    When I first tried to write settings from the old setup, I got an error saying that the operating systems didn't match. I then hand copy-and-pasted all the settings from the old transmission into the new and re-flashed the vehicle. Speedo still does not work; it moves, but it will read about 18mph at 50mph. I have no MIL at this time.

    Does anyone have any ideas?

  2. #2
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    8,894
    So the TCM wasn't flashed with the same OS/VIN as the computer?


    People run into this issue on the RWD 4L60e/6L80e if they got a used transmission. The TCM should be flashed with a dealer level tool, then it normally all jives together again.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  3. #3
    Potential Tuner
    Join Date
    Aug 2018
    Location
    Central New York
    Posts
    6
    Thanks for the reply.

    The ECM is the same, the VIN is the same, the TCM is different - but the NEW TCM was programmed with the OLD TCM settings. I was crossing my fingers to not get a dealer involved in this.......