Results 1 to 4 of 4

Thread: hellion 16 camaro voltage dip / bad misfiring on bank 2

  1. #1
    Tuner in Training hitmix300's Avatar
    Join Date
    Jun 2015
    Location
    detroit
    Posts
    17

    hellion 16 camaro voltage dip / bad misfiring on bank 2

    anybody ever have voltage issues with 16 camaro? this car has hellion twins and the problem started recently where the RH head starts misfiring on 6 & 8; the voltage seems to fluctuate alot.

    it seems to only do it after the vehicle is up to temp which makes me think it's heat related or something

    any advice would be appreciated thank you

    voltage drop.hpl
    2016 GenV 2SS twin turbo @20psi

  2. #2
    Potential Tuner
    Join Date
    Nov 2017
    Posts
    6
    Plug wires could be bad. Swap those wires with other cylinders & see if the misfires moves to the other cylinders

  3. #3
    Tuner Camaro6's Avatar
    Join Date
    Jun 2018
    Location
    Chicagoland
    Posts
    71
    Quote Originally Posted by hitmix300 View Post
    anybody ever have voltage issues with 16 camaro? this car has hellion twins and the problem started recently where the RH head starts misfiring on 6 & 8; the voltage seems to fluctuate alot.

    it seems to only do it after the vehicle is up to temp which makes me think it's heat related or something

    any advice would be appreciated thank you

    voltage drop.hpl
    Have you changed your voltage settings in the tune?
    2018 Camaro SS, LT4 Fuel System, LT4 S/C

  4. #4
    Tuner in Training hitmix300's Avatar
    Join Date
    Jun 2015
    Location
    detroit
    Posts
    17
    just a little follow up. wiring harness was getting super hot from downpipe. caused damage to the #8 injector wiring in the harness. so the car had lean condition in bank 2 and was adding fuel

    all the best
    2016 GenV 2SS twin turbo @20psi