Results 1 to 6 of 6

Thread: Track addict Cant Connect to ECU with Kiwi 2+

  1. #1
    Tuner in Training
    Join Date
    Oct 2018
    Posts
    14

    Track addict Cant Connect to ECU with Kiwi 2+

    Hi Track addict cant connect to the ECU using the Kiwi 2+ Bluetooth obd adapter. It tried a few other apps and they also couldn't. But NDS II android app (https://play.google.com/store/apps/d...an.ndsii&hl=en) can, but it is a Nissan specific app. This might be a problem with how mid 2000's Nissan ECU's work.

    Any ideas on how to get it to work with track addict?

  2. #2
    HPT Employee Weston@HPTuners's Avatar
    Join Date
    Jul 2014
    Location
    39.735034, -103.894459
    Posts
    778
    Assuming that TrackAddict is able to connect to the interface and is failing when it goes to connect to the vehicle (the status dialog or channel selection screen would get to at least "Connecting to Vehicle..."), you might try turning off the "Auto Protocol" feature... To get to that option, tap the little 'i' gear icon under the "OBD" section on the Options screen (OBD has to be turned on for the icon to appear).

  3. #3
    Tuner in Training
    Join Date
    Oct 2018
    Posts
    14
    Quote Originally Posted by Weston@HPTuners View Post
    Assuming that TrackAddict is able to connect to the interface and is failing when it goes to connect to the vehicle (the status dialog or channel selection screen would get to at least "Connecting to Vehicle..."), you might try turning off the "Auto Protocol" feature... To get to that option, tap the little 'i' gear icon under the "OBD" section on the Options screen (OBD has to be turned on for the icon to appear).

    I think the problem is K-Line, as per your HP MPV12 page "Select pre-2007 Infiniti Vehicles may be equipped with an older K-Line based ECM which is not supported" and this car is a 2006 Nissan Fuga, the JDM version of the Infiniti M45 and does use K-Line. So would I be correct to assume Track Addict also doesn't support a K-Line ECU'?

  4. #4
    HPT Employee Weston@HPTuners's Avatar
    Join Date
    Jul 2014
    Location
    39.735034, -103.894459
    Posts
    778
    Quote Originally Posted by Rob-bb View Post
    I think the problem is K-Line, as per your HP MPV12 page "Select pre-2007 Infiniti Vehicles may be equipped with an older K-Line based ECM which is not supported" and this car is a 2006 Nissan Fuga, the JDM version of the Infiniti M45 and does use K-Line. So would I be correct to assume Track Addict also doesn't support a K-Line ECU'?
    In theory it should work with a proper ELM327 compatible like the Kiwi 2+. Our MPVI2 should support K-line / ISO9141 in the future as well, but just didn't with its original firmware...

  5. #5
    Tuner in Training
    Join Date
    Oct 2018
    Posts
    14
    Quote Originally Posted by Weston@HPTuners View Post
    In theory it should work with a proper ELM327 compatible like the Kiwi 2+. Our MPVI2 should support K-line / ISO9141 in the future as well, but just didn't with its original firmware...
    I'll try it later without the auto protocol and see

  6. #6
    Tuner in Training
    Join Date
    Oct 2018
    Posts
    14
    Quote Originally Posted by Rob-bb View Post
    I'll try it later without the auto protocol and see
    It took me awhile to get around to it, but it still gets no where,