Results 1 to 9 of 9

Thread: 2017 6.2l 1500 Sierra / Rough Idle possibly bad cats? codes P0420 P0430 P050D

  1. #1
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    7

    2017 6.2l 1500 Sierra / Rough Idle possibly bad cats? codes P0420 P0430 P050D

    I have a 2017 6.2l 1500 Sierra with 1 7/8 ARH headers with ARH 200 cell high flow cats. I have a CEL throwing codes P0420, P0430, P050D. Upstream o2 sensors are disconnected shop did the tune and I had no CEL or issues untill now. At idle both downstream o2 sensors are around 0.7v and constantly dropping to 0.1v once a second or two consistent with the rough idle. Any ideas? If anyone needs me to log anything or some more info please let me know thanks.

    Edit: thought I included this Truck has 82k miles headers and hi flow cats were installed at 5k. also idle is around 630 rpm and should be around 900.
    Last edited by Wildlyfe200; 4 Weeks Ago at 04:52 AM.

  2. #2
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    8,495
    The front o2 sensors shouldn't have been disconnected, that is not a good sign if you ask me. That's a pretty stupid idea to disable all o2 sensor control, fuel trim control and closed loop operation.

    If the front o2 sensors are not working, those cat codes will always be there.


    Please post the tune file you have and you really should put the upstream o2 sensors back in the exhaust.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  3. #3
    Tuner in Training
    Join Date
    Sep 2014
    Posts
    11
    Quote Originally Posted by Wildlyfe200 View Post
    I have a 2017 6.2l 1500 Sierra with 1 7/8 ARH headers with ARH 200 cell high flow cats. I have a CEL throwing codes P0420, P0430, P050D. Upstream o2 sensors are disconnected shop did the tune and I had no CEL or issues untill now. At idle both downstream o2 sensors are around 0.7v and constantly dropping to 0.1v once a second or two consistent with the rough idle. Any ideas? If anyone needs me to log anything or some more info please let me know thanks.
    Your upstream O2s are removed/tuned out? I'm guessing you mean your post-cat sensors are removed. I know on my 2018 I had to leave the rear sensors physically connected and just tune them out. When I removed them entirely it caused all sorts of codes. I don't think it caused a rough idle, but I don't remember. I left mine connected and just zip-tied them to the frame. The P050D "rough idle" code could be anything. Did you try resetting the codes?

  4. #4
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    7
    I have not had codes for 80k miles and the Truck has ran great. ARH headers have no spot for the front O2's. here is the tune file

    https://www.dropbox.com/s/owcij3ekov...-%207.hpt?dl=0

  5. #5
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    7
    Yes I have the same set up as you only rears o2's connected. I have a feeling it is another issue nothing with the tune Vehicle has been running perfect for 80k. Yes I reset the codes and they came back on.

  6. #6
    Senior Tuner SultanHassanMasTuning's Avatar
    Join Date
    Nov 2009
    Location
    Jeddah, Saudi Arabia
    Posts
    2,158
    also log your individual cyl for misfire
    E-tuning/remote Tuning Sultan@mastuning.net Follow @MASTUNING Contact/Whatsapp +966555366161
    [URL="http://www.mastuningsaudi.com"]

  7. #7
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    7
    I will do that today and report back i did a tune up but that did fix the problem.

  8. #8
    Potential Tuner
    Join Date
    Jun 2017
    Posts
    7
    Problem fixed it was a misfire problem. This morning the CEL went off by itself after it ran for 5 minutes. Last night it ran for 45minutes like crap even after the tune up. I guess it was still in "limp mode" untill it ran another self test. The tune up did it but i did not reset DTC codes and assumed the problem was still there because it was running rough. I logged a 1hr drive this morning no misfires.

  9. #9
    Senior Tuner SultanHassanMasTuning's Avatar
    Join Date
    Nov 2009
    Location
    Jeddah, Saudi Arabia
    Posts
    2,158
    there you go
    E-tuning/remote Tuning Sultan@mastuning.net Follow @MASTUNING Contact/Whatsapp +966555366161
    [URL="http://www.mastuningsaudi.com"]