Results 1 to 4 of 4

Thread: 2015 Procharged Z06 cutting boost at 5500

  1. #1

    2015 Procharged Z06 cutting boost at 5500

    A customer brought me his 2015 Head/Cam Procharged Z06 on meth. The car was built on the other side of the country by a reputable shop and made 856 RWHP. He came to me for a few drivability issues mostly low rpm bucking and felt that the car was low on power. Well it was, the car made almost identical power as the building shop up to 5500-6000 and then power just fell off quickly and boost fell sharply, only made 737rwhp @ 5400 at 15psi. I have an entire day into figuring out this problem and have come up empty handed. The boost solenoid is removed, so no computer boost dump. The TPS stays wide open, Fueling is not being cut and timing does not drop. Fuel cut type stays none, torque management advance stays at zero and throttle control says torque. I have pulled this car a dozen times and my first made it to 6K, all other pulls 5400-5500. IDC 23.5%, fuel pressure 2888 psi. I couldnt find a torque issue, so i tried to lower the torque to see if it helped, it didnt engine torque went down but the car cut power at 4500 and went in limp mode This was my last pull, i was logging every torque and management pid i could find.

    Thank You
    Bad383TA
    Attached Files Attached Files

  2. #2
    Advanced Tuner
    Join Date
    Oct 2009
    Posts
    265
    A couple things come to mind that I didn't see after a quick look at the log.

    What is the camshaft doing at that rpm? Does the VVT advance change suddenly. It the cam timing locked out physically or does it still have some movement?

    What does the bypass valve do? I imagine this car has a big red Procharger valve on it. It that staying shut during the run?

    A blower is going to move air at rpm, so if that air isn't creating pressure in the manifold, it has to be going somewhere. You options are it never makes it into the engine, or it goes straight through the combustion chamber and out the exhaust valve before it can build any pressure.

    Good luck, I know from experience how frustrating these things can be, especially when you didn't build the car.

  3. #3
    Advanced Tuner
    Join Date
    Oct 2009
    Posts
    265
    Also, what is interesting is that the MAP reading drops all the way down to 39kpa, so you're actually getting vacuum in the manifold. I wonder if the throttle body is getting pulled shut? Is it stock?

  4. #4
    Advanced Tuner
    Join Date
    Jun 2006
    Location
    New York- South Florida
    Posts
    519
    Looks like you need a better PID list to log. Where is actually throttle angle? Most likely this is an issue related to throttle closure but all we can do is guess. When power drops off that hard its most likely airflow. Based upon the MAP readings this makes sense. When you confirm its the throttle then you can fix it

    EFI Performance Facility-South Florida Division
    (954) 703-5560

    SHOP TOUR!!

    www.redline-motorsports.net
    2006 ZO6 7.98@179 http://www.dragzine.com/news/video-r...ast-words-z06/
    2012 ZL1 10.22@139 LSX TV