Results 1 to 4 of 4

Thread: e67 comp, no PE above 2,600 rpm

  1. #1
    Potential Tuner
    Join Date
    Oct 2019
    Location
    lakewood wa
    Posts
    2

    e67 comp, no PE above 2,600 rpm

    born before the computer age, 2012 Colorado 5.3 with a 1900 supercharger, it has the tune supplied by the manufacturer, VCM scanner shows PE about 1,200 rpm to 2,600rpm then gone, running 14.68, 1 bar MAP, I'm towing a travel trailer, also my throttle position sensor reads 83.9% at full throttle, pedal signal say 100%, and I know TPS should read 88% at full throttle, Is this a dumb question??? i'm lost, just bought a wide band, won't be here for 10 days, need help
    Attached Files Attached Files
    Last edited by retracer; 3 Days Ago at 01:54 PM.

  2. #2
    Senior Tuner SultanHassanMasTuning's Avatar
    Join Date
    Nov 2009
    Location
    Jeddah, Saudi Arabia
    Posts
    2,198
    post the tune
    E-tuning/remote Tuning Sultan@mastuning.net Follow @MASTUNING Contact/Whatsapp +966555366161
    [URL="http://www.mastuningsaudi.com"]

  3. #3
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    8,610
    May need to lower the map enable from 100kpa down to 90kpa instead.

    I hope the transmission is up to snuff too, that tune is pretty aggressive for a stock 4L60e.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  4. #4
    Potential Tuner
    Join Date
    Oct 2019
    Location
    lakewood wa
    Posts
    2
    thanks 5FDP, i'll give it a try, I rebuilt the trans last year its full of sonnax stuff, oops looks like that will only make PE come in sooner, I'm worried about no PE above 2600rpm, above 2600 I show no PE, and the AFR is 14.68, truck is supercharged too
    Last edited by retracer; 5 Days Ago at 06:07 PM.