Results 1 to 4 of 4

Thread: 2012 Challenger R/T Comp 274 Cam Hanging Revs / Running Away / Slow Coastdown

  1. #1
    Potential Tuner
    Join Date
    Sep 2019
    Location
    San Diego
    Posts
    1

    2012 Challenger R/T Comp 274 Cam Hanging Revs / Running Away / Slow Coastdown

    Hi guys, I'm new to the MOPAR side of tuning and having some trouble with a car I just put together for a buddy. Specs on the car are as follows: 2012 Challenger R/T, 5.7, M/T, COMP Cams 274 phaser limiter cam (w/ limiter, of course), FIC 775cc/min Injectors, ARH 1 3/4" long tubes with off-road pipes, K&N CAI. As fuel, airflow, and spark goes the vehicle is otherwise stock. Currently, I have the ANN turned off because I couldn't seem to reel in the way-too-big injectors or make it idle with it on, and the car starts up, idles, runs and drives fine, the way-too-big injectors the kid ordered have actually proven quite responsive and easy to reel in so far, etc.... All is well EXCEPT for the fact that it intermittently hangs the revs while rolling, constantly suffers from a slow coast down to idle no matter the driving conditions, and in some cases (while rolling) when the clutch is pushed in and I take my foot off the gas the car will simply run up to a certain RPM (seems to love about 2500 and 3500) and stay there until the car stops moving. I've found plenty of info on the forum so far about various similar issues but nothing that seems to be exactly the same issue I'm having at the moment. I've tried a few things with various tables but mostly using Trial-Error-Reset tactics and I'm still totally at a loss as to how I can get rid of the rev hang.

    Included in the post are a stock tune file, the current tune file flashed to the car, and a log file from this morning. Unfortunately the problem wasn't as apparent during this run as was this afternoon (no adjustments in between the two runs) but I accidentally lost that log file. I'm hoping the supplied one helps but if it doesn't I can always go run the car again and post up another one.

    Just hoping someone on here would be so kind as to let me know exactly what I've F__d up.. I'm happy to supply any more info anyone might need about the car and as always any assistance is greatly appreciated!
    Attached Files Attached Files

  2. #2
    Tuner coanan's Avatar
    Join Date
    Mar 2009
    Location
    S. Florida
    Posts
    198
    Quote Originally Posted by 376TurboFire View Post
    Hi guys, I'm new to the MOPAR side of tuning and having some trouble with a car I just put together for a buddy. Specs on the car are as follows: 2012 Challenger R/T, 5.7, M/T, COMP Cams 274 phaser limiter cam (w/ limiter, of course), FIC 775cc/min Injectors, ARH 1 3/4" long tubes with off-road pipes, K&N CAI. As fuel, airflow, and spark goes the vehicle is otherwise stock. Currently, I have the ANN turned off because I couldn't seem to reel in the way-too-big injectors or make it idle with it on, and the car starts up, idles, runs and drives fine, the way-too-big injectors the kid ordered have actually proven quite responsive and easy to reel in so far, etc.... All is well EXCEPT for the fact that it intermittently hangs the revs while rolling, constantly suffers from a slow coast down to idle no matter the driving conditions, and in some cases (while rolling) when the clutch is pushed in and I take my foot off the gas the car will simply run up to a certain RPM (seems to love about 2500 and 3500) and stay there until the car stops moving. I've found plenty of info on the forum so far about various similar issues but nothing that seems to be exactly the same issue I'm having at the moment. I've tried a few things with various tables but mostly using Trial-Error-Reset tactics and I'm still totally at a loss as to how I can get rid of the rev hang.

    Included in the post are a stock tune file, the current tune file flashed to the car, and a log file from this morning. Unfortunately the problem wasn't as apparent during this run as was this afternoon (no adjustments in between the two runs) but I accidentally lost that log file. I'm hoping the supplied one helps but if it doesn't I can always go run the car again and post up another one.

    Just hoping someone on here would be so kind as to let me know exactly what I've F__d up.. I'm happy to supply any more info anyone might need about the car and as always any assistance is greatly appreciated!
    Copied from another persons experience.
    just +40% on Throttle Body Airflow table and around +30% on both Desired Throttle Large & Small Range.
    2012 Challenger CompCam 274.hpt
    2013 Chrysler 300S, 6.4 BGE with 6.4 SRT cam, AIT 18% OD pulley, E-force with 2.62 pulley(11.4 lbs boost??), fastman 84+4 mm throttle body, 1 7/8 kooks long tubes w/hi-flow cats, 3" Magnaflow Cat-back, FTI 2800 stall, Trans built by Hellraiser, Dings Racing valve body and tune, Getrag 3.73, Walbro 400LPH, DW 65# inj. LG aluminum rad. Dual SRT fans. Complete 4 piston Brembo upgrade. Stage one MOPAR springs, XIX X39 22x9 +15 - 22x10.5 +22 with NITTO NT555 265/35R22 - 295/30R22

  3. #3
    Tuner in Training
    Join Date
    Sep 2017
    Posts
    21
    ANN tuning is tricky, there is a lot of good info on here though about how to go about tackling it. I'm still in the learning stages with regards to that. Good luck

  4. #4
    Advanced Tuner
    Join Date
    Nov 2017
    Posts
    298
    Do you have accurate injector data?