Results 1 to 2 of 2

Thread: Stickshift 274 Cam High Idle Creep 2011 Challenger SRT8

  1. #1
    Potential Tuner
    Join Date
    Aug 2019
    Posts
    1

    Stickshift 274 Cam High Idle Creep 2011 Challenger SRT8

    I just finished buttoning up my build, but I'm struggling to get the car to idle correctly, as well as not max out my STFT/LTFT quickly. After I reset the adaptives in the scanner, I fire up the car and it idles great. But as it continues to idle and warm up, the idle gets increasingly higher and the engine begins to pull timing to compensate as it maxes out my trims. I'm very new to HP tuners and looking for whatever help I can get. I have attached the current log, as well as a tune that was created with the help of another forum member who has been carrying me through this process. But at the moment, we're both stumped. I have checked EXTENSIVELY for vacuum leaks, and do not currently believe that to be the issue. I appreciate the help, as I am very green to EFI tuning, and thank you in advance!

    Relevant Build Details: ANN off, stock shortblock 2011 392 six speed car, ported heads, ported intake, comp cam (very similar to a 274, but a little more intake lift at .632 and a little less intake duration, exhaust grind is identical), stock throttle body, stock injectors, cold air intake, long tube headers and currently no exhaust (open headers with only primary 02s). I should have a wideband on the car soon, but currently do not.

    Wednesday Idle and Drive with trans modified tune.hplBase Tune revision for manual.hpt

  2. #2
    Tuner coanan's Avatar
    Join Date
    Mar 2009
    Location
    S. Florida
    Posts
    194
    Quote Originally Posted by ThatMoparDude View Post
    I just finished buttoning up my build, but I'm struggling to get the car to idle correctly, as well as not max out my STFT/LTFT quickly. After I reset the adaptives in the scanner, I fire up the car and it idles great. But as it continues to idle and warm up, the idle gets increasingly higher and the engine begins to pull timing to compensate as it maxes out my trims. I'm very new to HP tuners and looking for whatever help I can get. I have attached the current log, as well as a tune that was created with the help of another forum member who has been carrying me through this process. But at the moment, we're both stumped. I have checked EXTENSIVELY for vacuum leaks, and do not currently believe that to be the issue. I appreciate the help, as I am very green to EFI tuning, and thank you in advance!

    Relevant Build Details: ANN off, stock shortblock 2011 392 six speed car, ported heads, ported intake, comp cam (very similar to a 274, but a little more intake lift at .632 and a little less intake duration, exhaust grind is identical), stock throttle body, stock injectors, cold air intake, long tube headers and currently no exhaust (open headers with only primary 02s). I should have a wideband on the car soon, but currently do not.

    Wednesday Idle and Drive with trans modified tune.hplBase Tune revision for manual.hpt
    Start comparing.
    https://forum.hptuners.com/showthrea...Slow-Coastdown
    2013 Chrysler 300S, 6.4 BGE with 6.4 SRT cam, AIT 18% OD pulley, E-force with 2.62 pulley(11.4 lbs boost??), fastman 84+4 mm throttle body, 1 7/8 kooks long tubes w/hi-flow cats, 3" Magnaflow Cat-back, FTI 2800 stall, Trans built by Hellraiser, Dings Racing valve body and tune, Getrag 3.73, Walbro 400LPH, DW 65# inj. LG aluminum rad. Dual SRT fans. Complete 4 piston Brembo upgrade. Stage one MOPAR springs, XIX X39 22x9 +15 - 22x10.5 +22 with NITTO NT555 265/35R22 - 295/30R22