Results 1 to 2 of 2

Thread: Launch timing control using KR

  1. #1
    Tuner in Training
    Join Date
    Jan 2018
    Posts
    10

    Launch timing control using KR

    Started this thread in the lounge - thinking it might be more appropriate in here. Basically I'm feeding the knock sensor inputs with a pulse generator in order to cut timing on the line after the turbo has spooled.

    I've gotten the circuit working in neutral but can't seem to get it to work under load. Hoping some big guns can chime in. Here are some pics of the issue:
    knock1.PNG
    Off screen I'm turning the circuit off which is causing the KR to decay - this will be run in parallel with my t-brake.
    knock2.PNG
    I'm on the t-brake in this pic, see how the KR doesn't increase once it sees engine load?

    Car is a '65 Tempest 4.8 s475 th400 transbrake. Thing lanuches TOO hard, and so I've heard the trick is letting the turbo reach critical mass but cut timing.

    I've attached a tune and scan as well.
    Attached Files Attached Files
    Last edited by Gianelli280; 12-05-2019 at 09:28 PM.

  2. #2
    Tuner in Training
    Join Date
    Jan 2018
    Posts
    10
    Found this in another post and think it might be the answer "...it can't pull timing if both tables are the same." Since both tables are the same for me would this prevent a knock event from pulling timing? It seems strange it would do it with no load vs loaded and high/low octane tables are almost identical.
    I'd just change tables and give it a shot but I'm in the middle of header fab.