Results 1 to 5 of 5

Thread: AEM 30-0334 Boost Analog Logging, Need Help Converting the Volts to PSI w/MPVI

  1. #1
    Advanced Tuner 2therock's Avatar
    Join Date
    Jun 2009
    Location
    N. GA
    Posts
    521

    AEM 30-0334 Boost Analog Logging, Need Help Converting the Volts to PSI w/MPVI

    Its been years and I'm rusty,
    I connected the + & - wires from the AEM 30-0334 boost gauge to the MPVI enhanced I/O and my gauge is reading in volts, not PSI and googling and pecking around has not bared fruit for me.
    I went through this back in 2005 but need the next steps from this point again.

    Any help or links will be much appreciated.
    2013 Dodge Charger R/T Plus, Stock 5.7L, Edelbrock E-Force Stage 1, 3.25" Pulley, 450-HP 459-TQ.
    Corsa Sport CatBack, 3.06:1 Wavetrac.
    2005 Radix'd Silverado L33 5.3 ECSB Z71 @ 387-HP 395-TQ

  2. #2
    Advanced Tuner Montecarlodrag's Avatar
    Join Date
    Nov 2009
    Location
    Pegasus Galaxy
    Posts
    916
    That model gauge is a wideband controller not a boost gauge.
    You also need to provide enough information. What version of the scanner are you using?
    9 sec Montecarlo SS

  3. #3
    Advanced Tuner 2therock's Avatar
    Join Date
    Jun 2009
    Location
    N. GA
    Posts
    521
    How Embarrassing,
    Its the AEM 30-0306 X-Series Boost Gauge.

    I'm using scanner version 4.4.2. Thanks.
    2013 Dodge Charger R/T Plus, Stock 5.7L, Edelbrock E-Force Stage 1, 3.25" Pulley, 450-HP 459-TQ.
    Corsa Sport CatBack, 3.06:1 Wavetrac.
    2005 Radix'd Silverado L33 5.3 ECSB Z71 @ 387-HP 395-TQ

  4. #4
    Advanced Tuner 2therock's Avatar
    Join Date
    Jun 2009
    Location
    N. GA
    Posts
    521
    I'm trying, pecking away at it but cannot get it to show up. I need step by step I guess.

    2013 Charger R/T 57L Edelbrock E-Force supercharger.
    I have their MAP sensor utilized and the white and brown wires terminated as instructed going to the Enhanced I/O plug on the interface.

    I google my behind off but cannot get the level of help I need.

    Thanks
    2013 Dodge Charger R/T Plus, Stock 5.7L, Edelbrock E-Force Stage 1, 3.25" Pulley, 450-HP 459-TQ.
    Corsa Sport CatBack, 3.06:1 Wavetrac.
    2005 Radix'd Silverado L33 5.3 ECSB Z71 @ 387-HP 395-TQ

  5. #5
    Tuner
    Join Date
    Jan 2015
    Location
    Arizona
    Posts
    60
    Quote Originally Posted by 2therock View Post
    I'm trying...cannot get the level of help I need.

    Thanks
    Quote Originally Posted by 2therock View Post
    Thanks, I wish someone would see my Boost 30-0306 thread and help me configure it. Its kicking my rear.
    i came here from the other thread, and found nothing here either. What did you end up doing? Im hoping you got it figured out in 3 years time span??