Results 1 to 2 of 2

Thread: 5.7 to 6.4 swap in 13 Ram 1500 Back fire and limp mode

  1. #1
    Potential Tuner
    Join Date
    Sep 2019
    Location
    Luling Louisiana
    Posts
    2

    5.7 to 6.4 swap in 13 Ram 1500 Back fire and limp mode

    Only my second post. I swapped in a 2016 6.4 from a wrecked challenger. I have everything hooked up and the truck starts and runs but is throwing a bunch of codes.

    PO300 Random Misfire - I have gone through all vacuum lines exhaust and checked wiring all are good
    P0052 O2 Sensor 2/1 Heater circuit high - The cats are gone but I don't have a tune to remove one of the O2 sensors - How do I do that?
    P0132 O2 Sensor 1/1 Circuit High - same as above
    P0032 O2 Sensor 1/1 Heater Circuit High - same as above
    P2122 Accelerator Pedal Position Sensor 1 circuit low
    P0750 LR Solenoid Circuit
    P0846 2-4 or 2C Pressure Switch Rationality
    P0935 Line pressure sensor circuit high
    P0058 2/2 Heater Circuit High
    P0443 Evap Purge Solenoid Circuit


    The ECM is the 2013 Ram 5.7 Computer on the 6.4 motor.

    Fuel Pressure 54.8
    MAP 9.7
    Spark adv 4.5
    IAT 95 degrees
    TPS% 16.5

    I have attached the base tune or what the truck is running off of currently. Any suggestions or direction to get a tune to get it running correctly is greatly appreciated. Thanks in advance and stay safe.

    Motor is backfiring and if I try and drive it any it goes into limp mode with the lighting bolt flashing.
    Attached Files Attached Files
    Last edited by TunaSRT; 2 Days Ago at 06:50 PM. Reason: Additional information the motor is backfiring and if I try and drive any distance it will go into limp mode

  2. #2
    Tuner in Training
    Join Date
    Apr 2019
    Posts
    21
    Im pretty sure the Ecm is different between the 13 and 16 , personally i would try to buy the engine with the original ecm