Results 1 to 7 of 7

Thread: Cammed ls3 won't hot start with blower

  1. #1
    Advanced Tuner
    Join Date
    Jun 2018
    Posts
    224

    Cammed ls3 won't hot start with blower

    So the car is a LS3 Camaro with a btr stage 3 cam and we just installed an ECS supercharber kit. Car runs great but won't hot start. So if it's been running a while it won't start. Once it cools down it fires right up. Any ideas where I should start?

  2. #2
    Advanced Tuner
    Join Date
    Jun 2018
    Posts
    224
    So I tried to start it with the wide band on and nothing. It didn't even budget when the car was turning over. Fuel rail had pressure in it and the car started and ran perfect right before that.

  3. #3
    Advanced Tuner
    Join Date
    Jan 2014
    Location
    Clinton MD
    Posts
    573
    Try startup airflow
    Daily Driver= 2016 Infiniti Q50 Red Sport 400
    Weekend Cruiser= 2009 Pontiac G8 GT (Vararam, TSP LS3 N/A Stage 1, OBX, CTS-V converter, MagnaFlows w/ J-Pipes, 160 t-stat)
    Project Car= 1991 Chevrolet Camaro RS (LQ4 w/ Gen 4 Rods, LS3 heads, 7875, 4L80 coming together )
    Truck= 1995 K1500 ECSB 5.0 5-speed (Dusty...)

  4. #4
    Advanced Tuner
    Join Date
    Nov 2006
    Posts
    426
    Start up airflow should fix it.

    Some aftermarket fuel systems have check valves in them that cause vapor lock heat soaked engine off. You can check for this by logging fuel pressure at start up. Up to about 75psi is ok. 90+ and the injectors won't open and car will not start.
    Tuner at PCMofnc.com
    Email tuning!!!, Mail order, Dyno tuning, Performance Parts, Electric Fan Kits, 4l80e swap harnesses, 6l80 -> 4l80e conversion harnesses, Installs


    10 Camaro LS3 M6 - TVS PCM '545 cam 696 rwhp
    07 Trailblazer SS Jackshaft TVS 2300 PCM '545 cam 648rwhp
    06 Silverado Magnacharged

  5. #5
    Advanced Tuner
    Join Date
    Jun 2018
    Posts
    224
    Start up air flow? I'll give it a try but the car doesn't seem to be getting any fuel when this happens. AFR on my wide band didn't even move. The fuel system is pretty much stock. Stock lines, stock rails with a DSX aux pump and some FIC 127lb injectors.

  6. #6
    Advanced Tuner
    Join Date
    Jun 2018
    Posts
    224
    Culprit was the map sensor. Didn't know we tossed a 3bar ls9 map sensor in with this kit. Just had to update the tune and it fires right up

  7. #7
    Advanced Tuner
    Join Date
    Jan 2014
    Location
    Clinton MD
    Posts
    573
    Good find
    Daily Driver= 2016 Infiniti Q50 Red Sport 400
    Weekend Cruiser= 2009 Pontiac G8 GT (Vararam, TSP LS3 N/A Stage 1, OBX, CTS-V converter, MagnaFlows w/ J-Pipes, 160 t-stat)
    Project Car= 1991 Chevrolet Camaro RS (LQ4 w/ Gen 4 Rods, LS3 heads, 7875, 4L80 coming together )
    Truck= 1995 K1500 ECSB 5.0 5-speed (Dusty...)