Results 1 to 6 of 6

Thread: 2010 LNF cold idle surge & cat delete

  1. #1

    2010 LNF cold idle surge & cat delete

    Working on an lnf that had a trifecta ECU and swapped out for a brand new GM e69.

    I'm not finding the cat disable anywhere. I have COT disabled as well as cat warmup cam tables matching the corresponding normal warm tables.

    Issue I'm having is on dead cold starts, idle shoots up to 1300-1400rpm, TPS steady at 23-25%, fuel pressure desired and actual at ~1300psi or so, and spark down at around -25. Looks like spark is trying to bring idle down but can't because the TB is at 25%. During this, you can hear the turbo surging/fluttering. It will stay like this untill it warms up to about 135-140ect. then idles normal at commanded RPM and positive timing and normal fuel pressure. Tried commanding 900rpm everywhere and no change.

    It does this with stock DALs and timing tables in the idle regions. Heck, it does it with the completely stock tune I got from GM. Plug in the trifecta ECU and cold starts have a little flare up to 1400rpm but instantly comes down to 800rpm, normal fuel pressure, 5%tps, and positive spark.

    This car was bought already modded and still unsure of everything that's been done so maybe they have a bigger TB? Different injectors? This car does have the problematic AEM CAI (or so I've heard) but don't think that would be causing this issue.

    Also did a write entire just in case with no success. I've had a few instances with corrupted files before so I figured I'd give that a try.

    My next idea was to bring the DALs down on the upper left corner of the table to see if I can bring the TPS down but why would this only affect cold startup?

    Tune and log later today

    TIA!
    Last edited by SQUEEGIO; 4 Weeks Ago at 03:22 PM.

  2. #2
    Am I completely missing the cat warm up disable switch or is it no longer there?

    Start up log below 140ect (high idle issue)
    Start up above 140ect (normal)
    Trifecta ecu which starts up normal no matter what ect.
    My tune (based off of GMS1)
    Stock tune from dealer.

    LNF start up below 140ect.hpl
    LNF start up above 140ect.hpl
    Trifecta.hpl
    5-31 write entire.hpt
    2010 Cobalt SS GM STOCK.hpt
    Last edited by SQUEEGIO; 4 Weeks Ago at 05:26 PM.

  3. #3
    Advanced Tuner
    Join Date
    Feb 2010
    Location
    The Desert
    Posts
    477
    Go into VCM editor, open your tune and then press CTRL+N to go to the navigator. From there, Engine - Exhaust - Catalyst

    What you're describing as an issue is just the cat warm up. Good luck.
    Last edited by T-Man; 3 Weeks Ago at 06:37 PM.
    09 RY Cobalt SS Coupe - 19K miles - Bolt ons + 7163 ZFR, HP tuned on ethanol

    Sold - 09 SRTC Cobalt SS Sedan
    Totaled - 09 VR Cobalt SS Sedan
    Sold - 09 RY Cobalt SS Sedan

  4. #4
    Wow! I would've never found that! I checked an 09 file and there's an exhaust tab where all the other ones are but this 2010 file doesn't for some reason.

    Disabled now so I'll load it next chance I get and hopefully that does it.

    Thanks again T-man!

  5. #5
    Advanced Tuner ZeroBoostBuick's Avatar
    Join Date
    Aug 2008
    Location
    S.W. Ontario Canada
    Posts
    269
    Make sure you're in the Advanced view. With no tune loaded,.. In the Edit tab / view /

  6. #6
    Just wanted to update in case someone sees this later on.. Disabled cat warmup and idles good now on cold starts. Also found the under/over boost settings with CTRL+N!

    Thanks!