Results 1 to 4 of 4

Thread: 2007 suburban LTZ 4x4 new 35/12.50/20 s and Speedo is off 5 mph

  1. #1

    2007 suburban LTZ 4x4 new 35/12.50/20 s and Speedo is off 5 mph

    Can?t seem to get tire wizard to find correct adjustment. Current says 6.12 and gear ratio is 1.00. I actually tried several different sizes......20.3 was what calculator gave me and that made my Speedo way out of whack....I also tried setting my actual gear ratio at 3.73 which should be accurate and that?s a no go also. And small changes multiplier gives err and won?t let me change. So how do I actually get an accurate speedo if I can?t figure out the numbers on my own🤦*♂️🤦*♂️ Any help appreciated.

  2. #2
    Tuner dhoagland's Avatar
    Join Date
    Jun 2015
    Location
    Aubrey TX
    Posts
    139
    Post up your tune and you might get more response's....
    2011 Camaro 2SS Convertible L99 Bone Stock for now
    2003 Dodge 2500 5.9 Cummins QC 4x4. Airaid, 2nd Gen Intake, Grid Heater Delete, D-Tech 62/65/12, Magnaflow. Bully Dog: Propane Injection, Triple Dog W/Outlook Crazy Larry. Edge EZ, BD Flow-Max, 48RE: Sonnax Sure Cure/Transgo combination, Derale turbulator, billet input, Triple Disc, Super servo, 4 ring Accumulator. :beer

  3. #3
    How do I do that? Do you have a link that explains how I do that? Thanks

  4. #4
    Advanced Tuner
    Join Date
    Mar 2011
    Posts
    515
    Some of the early 2007 OS's had some weirdness with the Tire/Gear ratio wizard. Specifically OS 12605898 reads exactly what you indicated...6.12" tire diameter and 1.00 gear ratio. I simply wrote a spreadsheet to calculate the PCM Output PPM. If you'll go to the speedometer tab, then click on Calibration, your PPM output is probably set at 97726. Change it to 88503 and see how close your speedo is. It should be very close.