Results 1 to 11 of 11

Thread: Audi A4 2.0T FSI Garrett GT30r big turbo race car

  1. #1
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7

    Audi A4 2.0T FSI Garrett GT30r big turbo race car

    Hello, I am working on a 2007 Audi 2.0T FSI big turbo race engine running the Bosch MED9.1 ECU. It is a track only car. I was originally running this car on a Motec M800 system running port injection. I have decided to try running the car on the original DI platform with the stock ECU. I fitted all the original necessary engine sensors - and deleted everything un-necessary - such as throttle flaps, evap system, rear O2 etc. As part of he big turbo DI build I put in the RS4 injectors, ARP HPFP and the RS4 140bar rail pressure relief valve. The Turbo is a Garrett GT30r with a billet wheel and Tial V-band hot-side housing along with a Tial external wastegate. I have a Billet intake manifold and front mount intercooler etc. The car also runs a dry sump oil system.

    I am looking for some help with the HP tuners tuning this Bosch MED9.1 ecu to work with my setup. And perhaps a understanding of this ECU's logic to tune it. Car runs and drives but is not happy under load. Looking for some advise on how I can raise the boost/torque etc.. Car currently cuts off at a maximum of 10psi boost. Id like to be around 20-25psi which should be in the 400+ WHP range.

    Also the car is ECU only with immo off. It is a caged racecar so no factory modules on CAN (ABS, gateway, TC, cluster, wheel speed, etc..) Just ecu and engine - as if it were stand alone.

    I have attached my bone stock ecu map I pulled from the ECU for backup and also my now 4th try at tuning the car.

    Help please
    Attached Files Attached Files

  2. #2
    Advanced Tuner
    Join Date
    Sep 2019
    Location
    ON, Canada
    Posts
    235
    Quote Originally Posted by dkjenis View Post
    Hello, I am working on a 2007 Audi 2.0T FSI big turbo race engine running the Bosch MED9.1 ECU. It is a track only car. I was originally running this car on a Motec M800 system running port injection. I have decided to try running the car on the original DI platform with the stock ECU. I fitted all the original necessary engine sensors - and deleted everything un-necessary - such as throttle flaps, evap system, rear O2 etc. As part of he big turbo DI build I put in the RS4 injectors, ARP HPFP and the RS4 140bar rail pressure relief valve. The Turbo is a Garrett GT30r with a billet wheel and Tial V-band hot-side housing along with a Tial external wastegate. I have a Billet intake manifold and front mount intercooler etc. The car also runs a dry sump oil system.

    I am looking for some help with the HP tuners tuning this Bosch MED9.1 ecu to work with my setup. And perhaps a understanding of this ECU's logic to tune it. Car runs and drives but is not happy under load. Looking for some advise on how I can raise the boost/torque etc.. Car currently cuts off at a maximum of 10psi boost. Id like to be around 20-25psi which should be in the 400+ WHP range.

    Also the car is ECU only with immo off. It is a caged racecar so no factory modules on CAN (ABS, gateway, TC, cluster, wheel speed, etc..) Just ecu and engine - as if it were stand alone.

    I have attached my bone stock ecu map I pulled from the ECU for backup and also my now 4th try at tuning the car.

    Help please
    please post up logs when you get a chance and use this channel config if you haven't made a proper one of your own

    2006-GolfGTI-2LT-Reduced.Channels.xml

  3. #3
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by TylerJDubbs View Post
    please post up logs when you get a chance and use this channel config if you haven't made a proper one of your own

    2006-GolfGTI-2LT-Reduced.Channels.xml
    Here is a quick drive around the block with the Scan file layout you gave. So I have noticed I cant see much on the scanner. Not many channels are displayed. Not sure why. Also I didn't mention - I do not have a MAF on this car. Here is the log
    AUDI Test Pull Diag.hpl

  4. #4
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by TylerJDubbs View Post
    please post up logs when you get a chance and use this channel config if you haven't made a proper one of your own

    2006-GolfGTI-2LT-Reduced.Channels.xml
    Here is a quick drive around the block with the Scan file layout you gave. So I have noticed I cant see much on the scanner. Not many channels are displayed. Not sure why. Also I didn't mention - I do not have a MAF on this car. Here is the log
    AUDI Test Pull Diag.hplAUDI Test Pull Diag.hpl

  5. #5
    Potential Tuner
    Join Date
    Feb 2021
    Posts
    7
    I believe that you use wrong injectors!
    The capacity is ok,but the injection angle is not for EA113 engine.
    In addition tell me please,what pistons did you fit? (I am asking because you said that you used PI)

  6. #6
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by Mactune View Post
    I believe that you use wrong injectors!
    The capacity is ok,but the injection angle is not for EA113 engine.
    In addition tell me please,what pistons did you fit? (I am asking because you said that you used PI)
    Yes the RS4 injectors I am told does not have the optimum spray angle for the 4 cyl FSI engine - but what I have seen is they are a common fuel upgrade for a bigger turbo setup on these engines. They are slightly bigger flow. RS4's for the FSI engine and S3 injectors for the TSI's. I am running a sacrificial completely stock long block in this car at the moment for testing - until the tune is working correctly. Once the car is running correctly I will swap engines to a built 2.0t engine, billet pistons 10:1 compression, H-beam rods and Golf R cams in the head etc.

  7. #7
    Advanced Tuner
    Join Date
    Sep 2019
    Location
    ON, Canada
    Posts
    235
    Quote Originally Posted by dkjenis View Post
    Here is a quick drive around the block with the Scan file layout you gave. So I have noticed I cant see much on the scanner. Not many channels are displayed. Not sure why. Also I didn't mention - I do not have a MAF on this car. Here is the log
    AUDI Test Pull Diag.hpl
    please make sure you are using the most recent beta?

  8. #8
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by TylerJDubbs View Post
    please make sure you are using the most recent beta?
    Ok, I do not have the BETA, I have the latest released version. I will get the BETA

  9. #9
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by TylerJDubbs View Post
    please make sure you are using the most recent beta?
    I got the Beta - I dont see any difference. Seems like Hp tuners just does not have the access to the MED 9.1 needed?

  10. #10
    Advanced Tuner
    Join Date
    Sep 2019
    Location
    ON, Canada
    Posts
    235
    Quote Originally Posted by dkjenis View Post
    I got the Beta - I dont see any difference. Seems like Hp tuners just does not have the access to the MED 9.1 needed?
    Select everything that is available for the engine and take a log for me please

  11. #11
    Potential Tuner
    Join Date
    Jul 2021
    Posts
    7
    Quote Originally Posted by TylerJDubbs View Post
    Select everything that is available for the engine and take a log for me please
    30psi 2.hpl

    Here is the latest log I just did. I installed a manual boost controller in line on the wastegate control line between the wastegate and the N75 valve which (chokes) the relief control. The turbo boosted a bit over 30psi boost on my gauge. The stock boost sensor looks like it maxes out at 2500mbar - but the engine ran very strong despite. So what is happening with the actual ecu map is - whenever it reaches around 10psi boost the N75 wastegate valve flips duty cycle and completely cuts the turbo. N75 duty is 95% pre 10psi (trying to build boost) - once it builds boost and hits around that10psi mark the duty flips to 0-5% and cuts the engine. with the inline manual boost controller that 10psi is still being triggered by the ecu but the physical control line is being manipulated to raise the boost. So when I set the manual around 20psi it does the same thing as it does at 10psi but now its at 20psi (total boost cut).

    Need to find out how to have the ecu allow more boost and not go into over boost cut/protection.

    Any ideas??