Results 1 to 6 of 6

Thread: 2017 CTS 2.0T trans issue resolved with close loop

  1. #1
    Tuner in Training
    Join Date
    Oct 2017
    Location
    Michigan
    Posts
    37

    2017 CTS 2.0T trans issue resolved with close loop

    Ok to start I'm new to this platform.
    Car has been in dealer 2 times for trans. has new gm tune and fluid. 1-2 shift still hard.
    In log I see short and long term fuel is way off.
    I go to special functions and do close loop and relearn. it shifts super smooth.
    At first I thought it was reading wrong as the fuel trims say 100%

    Oh it has zzp intake and catch can. and cleaned the maf. 44k miles.
    If anyone has a compare file it would be great!
    log file will not upload think it is to large. Have to log a shorter one and try again to post.

  2. #2
    Advanced Tuner
    Join Date
    Aug 2016
    Posts
    236
    Try putting the stock intake on and see if your fuel trims get back inline. If they do, then you need to adjust the MAF calibration table if you want to use that zzp intake. If they don't, then you've probably got an air leak somewhere (I'd be checking every line and valve with the catch can, or try removing it entirely also to see if the issue goes away).

  3. #3
    Advanced Tuner lt1z350's Avatar
    Join Date
    Mar 2014
    Location
    Jacksonville FL
    Posts
    522
    That intake needs a tune 100 percent. I do tons of those cars and a lot are on that intake

  4. #4
    Tuner in Training
    Join Date
    Oct 2017
    Location
    Michigan
    Posts
    37
    Hard for me to think the intake is the issue as it goes to the turbo. the maf is way on the end just before the throttle body. even if there was a large crack in pipes all there would be is lost air or boost from turbo. leak would need to be after the maf. the pvc has to be cut to add the catch can so I can't just remove it. Also I get knock.
    kristy test.hplkristy highway.hpl

  5. #5
    Tuner in Training
    Join Date
    Feb 2019
    Location
    Current Guamo
    Posts
    40
    Is not intake problem. Need minor adjust only. Nothing to cause this. I see fuel trim look fine. with 3% averags. Is a lot of slip rpm from switching gears. U need log WB EQ and DES MAP and any transmission pid u can find. I can help u as I get time

  6. #6
    Tuner in Training
    Join Date
    Oct 2017
    Location
    Michigan
    Posts
    37
    I added WB EQ and Desired MAP. Have to get another log file. Looks like I have to unlock the TCM to tune trans. I have credits for the engine tune, once I know what I'm doing. She is just complaining about the trans hard shifts. but like to clean up tune a little if I'm using the credits. Thanks