Results 1 to 9 of 9

Thread: cruising lean spikes

  1. #1
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6

    cruising lean spikes

    I am battling lean spikes while cruising 16.5-17.0 AFR, my set up is 99 silverado 4.3 5 speed with 52/65 T04E turbo 8 psi, p59 ecm swap, running closed loop speed density, marine intake 42lbs bosch injectors, ti automotive 450lph pump, boost reference regulator, catless straight 3 inch exhaust, it only does it while cruising between 2000-2500 rpm, lean spike happens OL and CL, I have swapped out several parts trying to find the issue with no luck, dont think its in the tune. I have tried adding fuel in the cells I cruise in but just makes it richer. Any insight would be appreciated. I attached tune file will try to get a log to attach.



    silverturdo clsd.hpt

  2. #2
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    12,547
    What it up with your VE table and injector settings?

    You typed out 42lb/hr injectors but the tune says it's running 22lb/hr injectors.

    If this tune doesn't even have the right injector data in it, good luck getting any fueling problems figured out.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

    If you don't post your tune and logs when you have questions you aren't helping yourself.

  3. #3
    Advanced Tuner
    Join Date
    Dec 2014
    Location
    Palmetto, FL
    Posts
    870
    If you would post a log up as well to help us see the area of concern.

    First and most important, the fuel injector data does not appear to have been adjusted for your larger fuel injectors.

    So to make sure, that I understand correctly. You are running the Multec2 Marine 8.1L injectors (green top o-ring)? To my knowledge there is no actual plug and play injector data available for these injectors.
    If those are the injectors you are running, here is a good start for injector data for your tune. (I have not ever personally used these injectors or the data from this link, but I know mowton knows what he is doing)
    https://forum.hptuners.com/showthrea...rine-injectors
    But being that you are boosted reference return, you will want to make sure the 0 kpa value is set the same across the entire IFR & Offset table (like you currently have in your tune, just with the correct data) that all being said with fuel pressure set at 58psi base

    Once you have correct the tune with the updated injector information, your VE table is going be off as you were previously making adjustments to it without updating the injector data.
    Fuel Injector data is one of the very first things that needs to be adjusted before trying to tune on a vehicle.

  4. #4
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6
    Sorry my laptop crashed so havent been able to log or or check forum, im using 03 cobra blue injectors dont remember part number off the top of my head, when i put 42 in for injector size couldnt get it to idle no matter where i set ve. ive been running it for almost 3 years on that tune without issue til about 3 weeks ago. I added msd 6AL-2 box about a week prior of lean spikes with msd coil and wires. I have since changed fuel pump, fuel filter, coil, wires, had injectors cleaned and flowed (which are 1% off each other), spark plugs (NGK tr6 4177), dizzy with cap and rotor, and tried with and without air filter, with and without msd box and 2 different narrow bands. Plan to log tomorrow now that i have laptop figured out

  5. #5
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6
    I also have a 79 c10 with cam and heads 5.3 4l60e and had similar issue about a year ago and turned out to be weak bosch 044 pump, but wasnt the case with my silverado. Thats where i started with this. Fuel pressure checks out fine 42 at idle 20 vacuum, 58 at 0, 66 at 8 psi

  6. #6
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6
    Here is log file from this morning.
    Attached Files Attached Files

  7. #7
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6
    i figured it out was the msd wires put autozone set back on and spikes went away, have a call into firecore for a set

  8. #8
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    12,547
    I'd still get real injectors with data so the fueling side of this thing is actually correct instead of just fudging the numbers to make it "work".

    You may say it runs okay but wait until all the injectors data is correct and the VE fueling is actually reflecting what is going on in that engine.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

    If you don't post your tune and logs when you have questions you aren't helping yourself.

  9. #9
    Potential Tuner
    Join Date
    Jun 2022
    Location
    East Texas
    Posts
    6
    thanks for the advice, i will mess it some and see if i can get it to idle, i believe i still have the file where i had ve kinda close with it set to 42 (that was 2 laptops ago so maybe i dont) just got fed up with the days of trying to get it to idle