Results 1 to 8 of 8

Thread: 6.2 Won't Idle

  1. #1
    Tuner in Training
    Join Date
    Nov 2022
    Posts
    11

    6.2 Won't Idle

    Hey Guys,
    I have a l92 with Long Tube Headers, Truck Norris Cam, K&N Cold air intake and other various mods. I can not get this to idle to even begin to try and tune. Can someone check this out and let me know what I got to do to get it to idle. The vehicle used to have a 5.3 and I got a good deal on this new 6.2.15.hpt24-05-19 12-16-17.hpl
    Last edited by Maverick70080; 4 Weeks Ago at 12:17 PM.

  2. #2
    Senior Tuner edcmat-l1's Avatar
    Join Date
    Aug 2006
    Location
    5BA8
    Posts
    3,640
    What are "other various mods"? Crank up the BRAF til it idles. You'll probably have to reset it later when you get everything thing else dialed in but if you add a bunch to your BRAF it'll probably idle on its own.

    EFI specialist
    Advanced diagnostics, tuning, emissions
    HPtuners dealer and tech support
    email=[email protected]

  3. #3
    Tuning Addict blindsquirrel's Avatar
    Join Date
    Apr 2017
    Location
    Meridian MS
    Posts
    8,100
    Which parts got reused from the LC9 and which are from the L92? (intake, TB, injectors, etc.)

  4. #4
    Tuner in Training
    Join Date
    Nov 2022
    Posts
    11
    New lifters, rods, rockers basically just some head work.

  5. #5
    Tuner in Training
    Join Date
    Nov 2022
    Posts
    11
    Quote Originally Posted by blindsquirrel View Post
    Which parts got reused from the LC9 and which are from the L92? (intake, TB, injectors, etc.)
    Heads, Intake, TB, Injectors all from LC9. New coils, plugs, and wires.
    Last edited by Maverick70080; 4 Weeks Ago at 02:04 PM.

  6. #6
    Tuning Addict blindsquirrel's Avatar
    Join Date
    Apr 2017
    Location
    Meridian MS
    Posts
    8,100
    Quote Originally Posted by Maverick70080 View Post
    Heads, Intake, TB, Injectors all from LC9.
    So the L92 has cathedral port heads instead of rect?

  7. #7
    Tuner in Training
    Join Date
    Nov 2022
    Posts
    11
    Yes it has the 243 heads from the lc9.

  8. #8
    Tuner in Training
    Join Date
    Nov 2022
    Posts
    11
    I actually think it is something electrical. I am getting a slew of codes.

    0x541: U0184 - Lost Communication With Radio (Pending, Current, Old, History)
    0x543: U0102 - Lost Communication with Transfer Case Control Module (Pending, Current, History)
    0x54E: C0575 (SES, Current, History)
    0x54E: C0580 (SES, Current, History)
    0x54E: C0585 (SES, Current, History)
    0x54E: C0615 - Left Front Position Sensor Malfunction (SES, Current, History)
    0x54E: C0620 - Right Front Position Sensor Malfunction (SES, Current, History)
    0x54E: C0660 - Level Control Exhaust Valve Circuit Malfunction (SES, Current, History)
    0x7E8: P0230 - Fuel Pump Primary Circuit (Pending, Current)
    0x7E8: P0532 - A/C Refrigerant Pressure Sensor A Circuit Low (Pending, Current, Old, History)
    0x7E8: P0615 - Starter Relay Circuit (Pending, Current, History)