Results 1 to 15 of 15

Thread: Mid range lag

  1. #1

    Mid range lag

    Hi I'm having some mid range performance issues. The issues is between 1800 and 3300rpm its acting almost like turbo lag but there is no turbo. Once PE kicks in I can really feel it pulling.

    I Just installed a 6.4cam with 6.4 springs and shorty headers in a 5.7hemi 2016 pursuit awd

    My Tune and log is posted looking to get this fixed. High rpm is really good just can't figure out the middle.midissuegoodhigh-work.hptlog.hpl

  2. #2
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    well yeah

    look at how retarded you are running the camshaft

    it is running exactly as it is commanded
    Attached Images Attached Images
    [email protected]

    don tanklage

  3. #3
    Quote Originally Posted by LilSick View Post
    well yeah

    look at how retarded you are running the camshaft

    it is running exactly as it is commanded
    So I should run the 6.4 values from a stock set? It's my understanding that the 5.7 will only read cam angle up to 125

  4. #4
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    125 is full advance and where it starts off

    at part throttle you have the cam retarded over 40 degrees from there

    if you hold the intake valve open for an extra 40 degrees how much stroke is left to compress the mixture?

  5. #5
    Quote Originally Posted by LilSick View Post
    125 is full advance and where it starts off

    at part throttle you have the cam retarded over 40 degrees from there

    if you hold the intake valve open for an extra 40 degrees how much stroke is left to compress the mixture?
    ok so i should bump that up to say 100 and try that

  6. #6
    Quote Originally Posted by hiwiredjuice View Post
    Hi I'm having some mid range performance issues. The issues is between 1800 and 3300rpm its acting almost like turbo lag but there is no turbo. Once PE kicks in I can really feel it pulling.

    I Just installed a 6.4cam with 6.4 springs and shorty headers in a 5.7hemi 2016 pursuit awd

    My Tune and log is posted looking to get this fixed. High rpm is really good just can't figure out the middle.midissuegoodhigh-work.hptlog.hpl

    Its really hard to see any "lag" when we have no idea what the Pedal is doing.
    Speaking of Pedal, You have some crazy DD and ETC stuff going on, don't wreck your car


    If this lag is supposed to be at Log time 00:17:13.0123, there looks like two different issues. One before the 94kPA MAP spike and one after it.


    Below 94kPa Map, it sure looks like WOT delay even though it appears disabled in the tune.

    After 94kPa spike, the Expected Torque is suspiciously flat until the TB decides it wants to open up more but the MAP is maxed out at Open Loop PE .



    I'd look at more info, like the aforementioned Pedal, all the Torques and Airflows as well as the Converter Clutch, AWD and Trans parameters. Then see if there's a clip on Airflow or Torque.
    Last edited by duster360; 4 Weeks Ago at 04:27 PM.

  7. #7
    Advanced Tuner
    Join Date
    Aug 2021
    Location
    Yorktown VA
    Posts
    205
    Yea, lots of odd stuff going on for sure.. but try this... maybe it'll help out a little and get you going in the right direction...
    2016 Ram CCSB Forged NA 396ci Stroker
    +2.5cc Flat/Dome Mahle Power-Pak Forged Pistons w/13.2/1 CR on E85
    Forged Manley 4.05" Stroke Crank/Speed Master Valvetrain
    Race Ported Eagles/Titanium 2.12"/Titanium 1.62" Valves
    Custom Cam 235/249 .629/.629 111LSA 110ICL+1Adv
    Ported Holley Hi-Ram Intake/NXpress Hi-Ram NO2 Plate kit w/250 Shot(4 sec)
    Tx Spd 2" Long Tubes/Active Viper Hood/2-Step
    ATI SD w/15% UD/Dual 450 Pumps/Fuel Cell in Bed/Demon 700cc Inj
    3800 stall/Det Tru-Trac/410 Gears

  8. #8
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    Quote Originally Posted by Spray-Cam Hell-Ram View Post
    try this... maybe it'll help out a little and get you going in the right direction...
    that is basically what i was suggesting...

    (bring max airflow back onto this planet and work on the cam tables)

    spray cam mighta tweaked more cam tables than your car or truck is gonna want tweaked

    there are three that i personally woulda tweaked further

    bet that ^^^ is a improvement tho???

  9. #9
    Quote Originally Posted by Spray-Cam Hell-Ram View Post
    Yea, lots of odd stuff going on for sure.. but try this... maybe it'll help out a little and get you going in the right direction...
    Thank you for the help i appreciate it.
    I updated everything in the tune. I didnt take a very long log and i stopped a couple of times but the mid range issue seems to be fixed but now im getting knock

    suggested.hpl

  10. #10
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    bad cam tune 1.png
    can you see that screen shot?

    this is what i was saying in my message

    4.4v at 25% throttle nfg

  11. #11
    Quote Originally Posted by LilSick View Post
    bad cam tune 1.png
    can you see that screen shot?

    this is what i was saying in my message

    4.4v at 25% throttle nfg
    I see it went from 110 and was fine no knock to 120 there is knock.
    So the correction would be to set the exhaust cam to 110 in that rpm range? or pull timing?

  12. #12
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    i wouldn't want it back 10 degrees there... maybe 3

    but that is not why its freaking out

    and 20 degree lead is not making 4.4v at 20% throttle either

    i believe it has to do with errors in the other cam tables

    i can fix it

    shoot me a email
    [email protected]

    don tanklage

  13. #13
    Quote Originally Posted by LilSick View Post
    i wouldn't want it back 10 degrees there... maybe 3

    but that is not why its freaking out

    and 20 degree lead is not making 4.4v at 20% throttle either

    i believe it has to do with errors in the other cam tables

    i can fix it

    shoot me a email

    OK sent you a email to the one at bottom of your post

  14. #14
    Advanced Tuner
    Join Date
    Jan 2022
    Posts
    997
    your laptop has OneDrive on it

    HP Tuners and OneDrive are not compatible

    attach the current tune here

  15. #15
    Quote Originally Posted by LilSick View Post
    your laptop has OneDrive on it

    HP Tuners and OneDrive are not compatible

    attach the current tune here
    I think I may have got it i will keep you posted