Results 1 to 9 of 9

Thread: Assign injectors to different cylinders?

  1. #1
    Tuner in Training
    Join Date
    Jul 2016
    Posts
    20

    Assign injectors to different cylinders?

    I have a running issue with my ls and I was trying to troubleshoot a slight hesitation or miss that I can hear when I rev the car. It's a standalone harness and then a 0411 Ecu. I hooked up hptuners scanner and tried to disable injectors one at a time but I have found that they don't correspond to the the cylinder number.

    C1 is injector 8, C2 is I5, C3 is I1, C4 is I2, C5 is I3, C6 is I4, C7 is I6, and C8 is I7...... Basically when I disconnected the cylinder 1 injector clip I had to disable injector 8 on hptuners scanner for it to actually turn off. I have a little noid light that I use to watch each injector turn off one at a time.

    I then checked continuity from the injector wire to the correct Ecu pin and they are correct. Injector 1 goes to injector control 1 and so on...

    I'm not really sure what else to check at this point. Can I change the injector assignment in hptuners or does anyone have any idea what might be going on?


    Zak

  2. #2
    Tuner in Training
    Join Date
    Jul 2016
    Posts
    20
    Nothin?

  3. #3
    Hey my man. More often then not posting a log and the tune will help . The ( Top tier guy's ) like to know what the are looking at . I am sure someone will hop on that !

  4. #4
    Senior Tuner cobaltssoverbooster's Avatar
    Join Date
    Dec 2008
    Location
    Nevada
    Posts
    4,175
    if you have double checked the disable with the correct firing order diagram and this is 100% the issue then under the Engine>General section there is a table in the p01 ecu's that is labeled firing order. Make sure your in advanced view or you cant see all the tables in the file.
    your other option is to physically re-pin the harness preferably at the ecu connector.
    Last edited by cobaltssoverbooster; 06-01-2018 at 10:49 PM.
    rdrfabrication@gmail.com
    2016 GMC 3500 Denali Diesel
    2000 Ford Mustang - Top Sportsman

    Ecotec help can be found here:
    LNF-http://www.hptuners.com/forum/showth...357-LNF-Guides
    LSJ-http://www.hptuners.com/forum/showth...965-LSJ-Guides

  5. #5
    Tuner in Training
    Join Date
    Jul 2016
    Posts
    20
    Hey James, thanks for the suggestion but I dont know how I would be able to actually record this on a scanner... Im physically checking the injector clip when I unplug and then disable it on the computer scanner

    Cobalt, I did check the firing order before to see if that correlated and it doesnt.

    Trying to explain it better...



    When I disable injector 1 ( should correspond to cylinder 1, right?) on the hptuners scanner, it actually turns off the injector for cylinder 3.... I dont have any injectors that correspond to the actual cylinder. I wasnt sure if it can be reassigned or not.

    I then checked the continuity between cylinder 1 injector location and ecu 1 injector control and its correct, each cylinder checks out ok.


    Here is a pic of the injectors that correspond to injector on scanner.


    IMG_7917.JPG

  6. #6
    Senior Tuner cobaltssoverbooster's Avatar
    Join Date
    Dec 2008
    Location
    Nevada
    Posts
    4,175
    ok if the ports match their proper locations and all your having is a scanner issue then i would report that to hptuners directly. as of now their is no way of changing disable cylinder locations in just the scanner alone.
    rdrfabrication@gmail.com
    2016 GMC 3500 Denali Diesel
    2000 Ford Mustang - Top Sportsman

    Ecotec help can be found here:
    LNF-http://www.hptuners.com/forum/showth...357-LNF-Guides
    LSJ-http://www.hptuners.com/forum/showth...965-LSJ-Guides

  7. #7
    Tuner in Training
    Join Date
    Jul 2016
    Posts
    20
    Thats a good suggestion, guess I wanted to make sure I wasnt missing something. Im going to try another ecu as well.

  8. #8
    Tuner in Training
    Join Date
    Dec 2012
    Location
    Arkansas
    Posts
    22

    Did you figure this one out?

    Quote Originally Posted by tictakman View Post
    Thats a good suggestion, guess I wanted to make sure I wasnt missing something. Im going to try another ecu as well.
    Did you ever figure this one out? I have the exact same problem.

  9. #9
    Potential Tuner
    Join Date
    Aug 2017
    Posts
    2
    Same, whats the status on this, I currently am having STLT Fuel trim issues, one o2 that fouls out constantly. Comparing HP Tuners INJ#, IF you ASSUME that number corresponds to CYL number then INJ/CYL 1,2,3,4 Affect the correct bank o2, CYL/INJ # 5,6,7,8 affect the what you would assume is the opposite bank.

    Firing order in advanced View is correct, but my chart does look odd. Firing order.JPG

    Current Tune

    Cylinder#/Injector# Injector# is the number from in Scanner using the disable function.
    1/8
    2/5
    3/1
    4/2
    5/3
    6/4
    7/6
    8/7

    anyone got any ideas? or do I just repin the harness so the Injector # match the Cylinder #s?

    -Chris
    Last edited by Turbine822; 4 Weeks Ago at 07:15 PM.