Results 1 to 3 of 3

Thread: 67 Impala with 5.3 DBW

  1. #1
    Advanced Tuner uarperformance's Avatar
    Join Date
    Apr 2007
    Location
    Redington Beach FL
    Posts
    226

    67 Impala with 5.3 DBW

    Have a 67 Impala that another company built. It is had multiple issues. I am down to the finish car and easy deccel even in neutral it loses the throttle body. shut off and restart most times it will have throttle again. A few times had to either wait or I played with harness at throttle body and I had throttle again possibly coincidence. I have messed with air flow numbers all over the place and still don't see where or why. The odd thing is it sets no fault codes except for tach RPM output. normal. According to the what I see in my tune it should set a code air flow mismatch. Compared it to many other cars I have on file and cant see anything standing out. If someone has some insight please. Have went to extreme on air flows and still nothing. ;>{
    Last edited by uarperformance; 09-13-2018 at 02:14 PM.

  2. #2
    Advanced Tuner uarperformance's Avatar
    Join Date
    Apr 2007
    Location
    Redington Beach FL
    Posts
    226
    Here one more little flip. I was backing the car out of the shop. Throttle worked, put it neutral it stopped working, put it in drive Had throttle again, never shutting it off. had wife get in car because we are closing. pull on harness as she is blipping the throttle, no throttle, put in drive and reverse No Throttle again. Shut it off again, start it back up, throttle only in foward or reverse. Not in neutral or park. WTH
    Attached Files Attached Files
    Last edited by uarperformance; 09-13-2018 at 06:41 PM.

  3. #3
    Advanced Tuner uarperformance's Avatar
    Join Date
    Apr 2007
    Location
    Redington Beach FL
    Posts
    226
    Here is another log. In shop getting it to stop having throttle
    Attached Files Attached Files
    Last edited by uarperformance; 09-14-2018 at 09:29 AM.