Results 1 to 3 of 3

Thread: Hi-speed cooling fan relay burns out

  1. #1
    Advanced Tuner coachcrow56's Avatar
    Join Date
    Dec 2004
    Location
    Longview, Texas
    Posts
    268

    Hi-speed cooling fan relay burns out

    I have a 2000 GTP, and twice in the past 2 weeks it has blown the Fan 1 relay. The strange part is, the fan 1 relay is burned at the #30 pin, but the low speed fan blowing on the AC compressor still works. Weird. The Fan 2 relay is still good. I have checked all fuses--good. The fans will run if power is run straight to them from a power source. Both fans turn freely with no resistance.
    What should I look for?
    Last edited by coachcrow56; 07-11-2019 at 09:45 AM.
    3.2 Pulley/CAI/1.6 HS Rockers/Hi Energy Comp Cam 76-802-9/LS7 Lifters/ZZP Intercooler/Headers/2500 Stall Converter/NGK TR6IX/ZZP Fuel Rails/100 shot NOS/GMPP Sway Bars//I forgot the rest!!!

  2. #2
    Sounds like your fan motor is drawing too much current. I'd recommend measuring the current draw and if it's out of spec, you probably need a new fan motor.

  3. #3
    Advanced Tuner coachcrow56's Avatar
    Join Date
    Dec 2004
    Location
    Longview, Texas
    Posts
    268
    I could never find the source of the problem. I purchased a high speed fan control unit from Casper Electronics and installed it. Now I have control of my high speed fans and no cooling issues
    during the 100 plus days in Texas.
    3.2 Pulley/CAI/1.6 HS Rockers/Hi Energy Comp Cam 76-802-9/LS7 Lifters/ZZP Intercooler/Headers/2500 Stall Converter/NGK TR6IX/ZZP Fuel Rails/100 shot NOS/GMPP Sway Bars//I forgot the rest!!!