Results 1 to 5 of 5

Thread: Help getting catalyst monitor to set.

  1. #1
    Potential Tuner
    Join Date
    Dec 2019
    Location
    Fairview, Or
    Posts
    8

    Help getting catalyst monitor to set.

    Hello fellow motor heads. I recently bought a 2012 charger r/t with a magnuson 2300 supercharger and longtube headers installed with 2 1/2 in exhaust from a deq exempt zone. well turns out i live in a deq zone and need to get a cert of compliance before i can register it. Looking at the tune that was on it i noticed the monitors turned off for it so i turned them on but i still cant get them to set. Any help is greatly appreciated. ill attach my before and after tune files so you can see what ive done so far. (base is prior, mon is with monitors)
    Attached Files Attached Files

  2. #2
    Advanced Tuner
    Join Date
    Mar 2018
    Location
    Illinois
    Posts
    496
    To get the monitor to start you need to meet the following conditions. However, most magnuson tunes disable a lot of engine diagnostics in the tune and set the downstream O2 sensor temps high so that they are never read. I have reverted my diagnostic and O2 temp back to stock was able to get all monitors to complete.

    FYI if need to know other drive cycles go to the chilton's online manual link in this post and search the on-board diagnostic section.
    https://www.challengertalk.com/threa...7/post-8494405

    Catalyst / O2 Monitor
    The Catalyst and O2 Monitor information are acquired and processed at the same time. Most vehicles will need to be driven at highway speed (less than 50 mph) (73km/h) for a few minutes. Some vehicles run the monitor at idle in drive. If the vehicle is equipped with a manual transmission, using 4th gear may assist in meeting the monitor running criteria.

    • Engine RPM between 1200 to 3000.
    • Engine temperature greater than 70C (158F)
    • Engine run time greater than 92 seconds
    • MAP between 10 - 20 kPa (7.5 - 15 Hg)
    • Vehicle speed between 20 - 70 mph (29?103 km/h)
    Last edited by Homer; 2 Weeks Ago at 12:39 PM.

  3. #3
    Potential Tuner
    Join Date
    Dec 2019
    Location
    Fairview, Or
    Posts
    8
    Thank you for the reply. Could you tell me where to find the O2 temps? I think I've reset all the engine diagnostics as far as the DTC's go. Funny you say that Magnuson turns off that stuff because when i was talking to them about this problem they said they don't change them. Then went on to tell me I could purchase their tune for $400 to replace the one I currently have

  4. #4
    Advanced Tuner
    Join Date
    Mar 2018
    Location
    Illinois
    Posts
    496
    Quote Originally Posted by robertkillinger View Post
    Thank you for the reply. Could you tell me where to find the O2 temps? I think I've reset all the engine diagnostics as far as the DTC's go. Funny you say that Magnuson turns off that stuff because when i was talking to them about this problem they said they don't change them. Then went on to tell me I could purchase their tune for $400 to replace the one I currently have
    They probably don't but the shop I bought the kit from provided a base tune with quite a bit of the diagnostics turned off. As for the O2 temp, this is table you are looking for.
    O2.JPG

  5. #5
    Potential Tuner
    Join Date
    Dec 2019
    Location
    Fairview, Or
    Posts
    8
    Quote Originally Posted by Homer View Post
    They probably don't but the shop I bought the kit from provided a base tune with quite a bit of the diagnostics turned off. As for the O2 temp, this is table you are looking for.
    O2.JPG
    Okay, I figured it was that one after looking through everything and you were right, it was set to 350?. I wish I had more information on this car, not even completely sure what all is done to it haha