Results 1 to 13 of 13

Thread: 2016 E80 ECM E85 Sensor

  1. #1
    Tuner in Training
    Join Date
    May 2019
    Posts
    32

    2016 E80 ECM E85 Sensor

    I heard that the E80 ECM for the 2016+ Cadillac and Camaro LTG engines cannot support an E85 sensor and only virtual tuning can be done. However, a few other companies have mentioned that it is just a different ecu pin in order to get the sensor working. Has anyone had any luck or experience with adding a flex fuel sensor to these cars?

  2. #2
    Advanced Tuner ZeroBoostBuick's Avatar
    Join Date
    Aug 2008
    Location
    S.W. Ontario Canada
    Posts
    232
    Give ZZPerformance a call. If anyone knows it's them.

  3. #3
    Tuner in Training
    Join Date
    Feb 2019
    Posts
    26
    Quote Originally Posted by scottyl View Post
    I heard that the E80 ECM for the 2016+ Cadillac and Camaro LTG engines cannot support an E85 sensor and only virtual tuning can be done. However, a few other companies have mentioned that it is just a different ecu pin in order to get the sensor working. Has anyone had any luck or experience with adding a flex fuel sensor to these cars?
    I have a '17 ATS LTG w/E80A ECM and was told the code had been cracked for Flex Fuel. Sensor has since been installed, but the sensor is not working currently. Working on figuring this out as I type. Hoping HPTuners can shed some light on the enable sensor option.

    -P

  4. #4
    Tuner in Training
    Join Date
    Feb 2019
    Location
    Current Guamo
    Posts
    34
    ZZP has said recently that flex fuel is solved and working on new HPT beta.. But I also can not get it to read on 3 different cars

  5. #5
    Tuner in Training
    Join Date
    Feb 2019
    Posts
    26
    Quote Originally Posted by Emily89 View Post
    ZZP has said recently that flex fuel is solved and working on new HPT beta.. But I also can not get it to read on 3 different cars
    Latest beta update works, confirmed it last night

  6. #6
    I installed the kit on my 2016 ats and it?s working but I can?t seem to get it to read the ethanol percent. It?s stuck at 4.3% already filled half the tank with e85. Updated to the most recent beta version and still same issue. How would I know if I?m getting signal to the ecm?
    Last edited by Vasquezz1228; 4 Weeks Ago at 03:48 PM.

  7. #7
    Tuner in Training
    Join Date
    May 2019
    Posts
    32
    What pin are you guys using on the E80? I already run E47 without the sensor and I noticed the sensor option for a while but didn't think it would work.

  8. #8
    I was told by zzp it was pin 70 on the x3 connector for the 16+

  9. #9
    Tuner in Training
    Join Date
    May 2019
    Posts
    32
    I enabled the sensor in the fuel management as well as the DTC's. The e85 sensor is still not working and is stuck at 4.3%, seeing no codes. 2016 ATS X3(Grey) Pin 70

  10. #10
    There is a new version of the vcm suite. Version 4.6 just got released. I?m on my way to work so will not be able to install and attempt to red lash the car. Worth a shot to see if the issue was fixed.

  11. #11
    Tuner in Training
    Join Date
    May 2019
    Posts
    32
    What sensor are you using? Maybe its a bad sensor. I was using 13577379. I ordered 13577394 to see if this one will work instead.

  12. #12
    Tuner in Training
    Join Date
    Feb 2019
    Posts
    26
    Code has been broken on the '17's I am currently running e85 on my LTG with the e80a ECM. Latest version on HP supports it now.

  13. #13
    Tuner in Training
    Join Date
    May 2019
    Posts
    32
    Thanks. I will test this in the AM.