Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Thread: Currently have a MPVI pro, afraid to update anything....

  1. #1
    Potential Tuner
    Join Date
    Jan 2009
    Posts
    9

    Currently have a MPVI pro, afraid to update anything....

    I have been hearing rumors that if I update my software that my older MPVI Pro will be bricked and I will be forced to buy the latest and greatest to keep using the software. Is this true, and if so is there any compensation for my old unit being obsoleted?

    Not looking for any arguments, just want proper answers!

    Mike

  2. #2
    HP Tuners Support
    (foff667)
    Bill@HPTuners's Avatar
    Join Date
    Jun 2004
    Location
    Hailing from Parts Unknown
    Posts
    26,540
    Not true.
    It doesn't have to be perfect, it just needs to be done in two weeks...

    A wise man once said "google it"

  3. #3
    Potential Tuner
    Join Date
    Jan 2009
    Posts
    9
    Quote Originally Posted by Bill@HPTuners View Post
    Not true.
    Which part or both?

    Mike

  4. #4
    Advanced Tuner
    Join Date
    Jan 2014
    Location
    Clinton MD
    Posts
    572
    Quote Originally Posted by schwoch1 View Post
    Which part or both?

    Mike
    Both
    Daily Driver= 2016 Infiniti Q50 Red Sport 400
    Weekend Cruiser= 2009 Pontiac G8 GT (Vararam, TSP LS3 N/A Stage 1, OBX, CTS-V converter, MagnaFlows w/ J-Pipes, 160 t-stat)
    Project Car= 1991 Chevrolet Camaro RS (LQ4 w/ Gen 4 Rods, LS3 heads, 7875, 4L80 coming together )
    Truck= 1995 K1500 ECSB 5.0 5-speed (Dusty...)

  5. #5
    Have you got an MPVI1 with V4.4+ and latest firmware working to read/write and log without issue? I know some folks had issues with V4.0+ and MPVI1 and it seemed to be hit/miss. I've been waiting two years to update but still cautious.

  6. #6
    Advanced Tuner mbray01's Avatar
    Join Date
    Dec 2013
    Location
    Slidell, La.
    Posts
    870
    If you use the cable professionally, i would recommend keeping the old cable, with older software, and if you need to have the new software for newer vehicles, i would purchase the newer cable and run the new with old software side by side. I run 2.24(on old cable), the latest beta version, and i log with 4.2(both cables[i use this version because for some reason it works best with eec-v mustangs])
    Michael Bray
    Rusty Knuckle Garage
    Slidell, Louisiana
    20yr Master Tech.
    Advanced Level Specialist
    Custom Car Fabrication, Customization, High Performance.
    GM World Class Technician
    Shop Owner

  7. #7
    HP Tuners Support
    (foff667)
    Bill@HPTuners's Avatar
    Join Date
    Jun 2004
    Location
    Hailing from Parts Unknown
    Posts
    26,540
    Quote Originally Posted by SSUte01 View Post
    Have you got an MPVI1 with V4.4+ and latest firmware working to read/write and log without issue? I know some folks had issues with V4.0+ and MPVI1 and it seemed to be hit/miss. I've been waiting two years to update but still cautious.
    I do, I have 5 MPVI1's that i've used for development testing that are all on 4.4+ and the newest firmware.
    It doesn't have to be perfect, it just needs to be done in two weeks...

    A wise man once said "google it"

  8. #8
    Quote Originally Posted by mbray01 View Post
    If you use the cable professionally, i would recommend keeping the old cable, with older software, and if you need to have the new software for newer vehicles, i would purchase the newer cable and run the new with old software side by side. I run 2.24(on old cable), the latest beta version, and i log with 4.2(both cables[i use this version because for some reason it works best with eec-v mustangs])
    Outstanding advice, I think that is exactly what I'll have to do. The newer software for new vehicles isn't as big of a concern as we don't have as many new vehicles to worry about and I'm not planning to branch into VW/Audi etc. Nissan interests me. I still use 3.6 and 2.24 side by side for different reasons.

    Quote Originally Posted by Bill@HPTuners View Post
    I do, I have 5 MPVI1's that i've used for development testing that are all on 4.4+ and the newest firmware.
    That is very reassuring, I appreciate the response.

  9. #9
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    9,806
    I'm still using the MPVI I bought in 2012. Original cable and everything on my 2016 truck with the last 4.5 beta on that computer. I'll keep it until I need the MPVI 2 or just buy it because I want it enough for the added features lol.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  10. #10
    Tuner in Training
    Join Date
    Nov 2013
    Posts
    45
    Trying to not go off topic but mpvi 1 pro with latest firmware does it support all the latest stuff or do I need the newer one anyways?

  11. #11
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    9,806
    Some vehicles require the MPVI2. You can read the supported vehicles list to see if a vehicle you are wondering about needs the MPVI2.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  12. #12
    Tuner in Training
    Join Date
    Nov 2013
    Posts
    45
    Thanks, I see I will purchase another old cable and update this one since i accidentally updated the firmware

  13. #13
    Potential Tuner
    Join Date
    Dec 2016
    Posts
    9
    I have two MPVI devices that are currently bricked and useless..... They both give Polling Failed messages. I've opened a support ticket with HP but no response......

    So I have to disagree with what is being said in this thread. If someone would help me I'd have a different opinion.

    Both had the same thing happen. I opened VCM Scanner software and it automatically started updating the firmware. Afterwards it would return the message "cannot detect vehicle protocol"

    Now I can't use them for vehicles that are licensed, I can't export EPQ files for use with Edge Insight pro devices because they don't recognize the license, its a joke.
    Last edited by HBSSROB; 04-08-2020 at 06:28 PM. Reason: added info

  14. #14
    HP Tuners Support
    (foff667)
    Bill@HPTuners's Avatar
    Join Date
    Jun 2004
    Location
    Hailing from Parts Unknown
    Posts
    26,540
    Quote Originally Posted by HBSSROB View Post
    I have two MPVI devices that are currently bricked and useless..... They both give Polling Failed messages. I've opened a support ticket with HP but no response......

    So I have to disagree with what is being said in this thread. If someone would help me I'd have a different opinion.

    Both had the same thing happen. I opened VCM Scanner software and it automatically started updating the firmware. Afterwards it would return the message "cannot detect vehicle protocol"

    Now I can't use them for vehicles that are licensed, I can't export EPQ files for use with Edge Insight pro devices because they don't recognize the license, its a joke.
    What is your support ticket number so I can check the status?
    It doesn't have to be perfect, it just needs to be done in two weeks...

    A wise man once said "google it"

  15. #15
    Advanced Tuner
    Join Date
    Jan 2014
    Location
    Clinton MD
    Posts
    572
    When I had my MPVI2, I always ran the firmware update while it was disconnected from the vehicle. Maybe that's what saved mine. I upgraded to the MPVI2 early 2019...

  16. #16
    Potential Tuner
    Join Date
    Dec 2016
    Posts
    9
    Quote Originally Posted by Bill@HPTuners View Post
    What is your support ticket number so I can check the status?
    Bill, first off THANK YOU for the reply.

    I can't find the email with the support ticket number and I'm having a hard time locating it on the user portal on the HPT site. Can you point me in the right direction to locate it. I currently have 4 customer vehicles waiting for updates that I can not provide because I can't connect to the device.

    Thank you in advance for your help.

    I could not find the case info anywhere so I started a new ticket:

    #214201
    Last edited by HBSSROB; 04-13-2020 at 01:12 PM. Reason: added support ticket number

  17. #17
    Tuner 00GrcyGtr's Avatar
    Join Date
    Jul 2016
    Location
    Westfield, IN
    Posts
    137

    Not as concerned, but now curious!

    Quote Originally Posted by Bill@HPTuners View Post
    I do, I have 5 MPVI1's that i've used for development testing that are all on 4.4+ and the newest firmware.
    So I am always like a kid with a new toy, (even with computer/software) related stuff, so I have the most recent version of software, with all my original 4 plus year old hardware. Cables included bein the original.
    I hadn't had any issues, and I'm not saying a post I am going to start is due to the mentions of new vs old cables, yada yada, but I guess now since my "time out issue during write" has happened, causing the p0606 ECM/TCM (processor, *****) I think it said (processor, pending), I know the second word is pending for sure, but anyway, I'll describe that here;

    https://forum.hptuners.com/showthrea...451#post607451

    So onto the question/s
    1. I noticed the term firmware updates and I don't seem to find this specifically anywhere to actually download and install (may be blind or missing it, so no complaints), but this makes me wonder (as sadly I can't recall) if this was done somehow automatically to the unit during all the updating process, is this the case or do I need to find and install my most recent firmware and what number and how do I find my current firmware versions?
      (keep in mind, I think of software as a program to operate on screen and firmware to make a device operate properly with the software so to speak) If the update is the firmware I may be ok, but would still like to compare numbers to be sure.
    2. My current Scanner is 4.6.3, and current editor is the same. and I installed all the new drivers.
    3. Is there something I need to do to my Pro Stand Alone unit? Is this where the "firmware goes? If so, how can I tell which firmware it has, or insure it is properly updated?
    4. I still use both cables that came with the unit a few years ago, is this really an issue? Is there something about the new cables that is better or needed?

    I'm kinda dealing with a somewhat random ECM-TCM P0606 error as mentione and better explaind in the linked post/thread above, so I figured more info/knowledge about what gives you the tune and data is as important as tuning and data info.

    Any help/direction or links will be appreciated.
    Last edited by 00GrcyGtr; 04-19-2020 at 11:00 AM. Reason: add a link
    __________________________________________________ __________________________________________________ __________________________________________________

    "To explain the lure of speed you would have to explain human nature; but it is easier understood than explained...Speed is the second oldest animal craving in our nature..." -- T. E. Lawrence
    2000 Regal GSE
    2007 Trailblazer SS

  18. #18
    HP Tuners Support
    (foff667)
    Bill@HPTuners's Avatar
    Join Date
    Jun 2004
    Location
    Hailing from Parts Unknown
    Posts
    26,540
    1. firmware is updated automatically via the editor/scanner software whenever the software sees you are using old firmware on your interface, no additional downloads necessary.
    2. 4.6.3 is the newest public software
    3. no there is nothing you need to do, VCM Suite infolog will tell you what firmware version you are running on your interface.
    4. if you are having connection issues the easiest and cheapest test is to replace the usb cable, if you are not having an connection issue you likely don't have a hardware issue.
    It doesn't have to be perfect, it just needs to be done in two weeks...

    A wise man once said "google it"

  19. #19
    Tuner 00GrcyGtr's Avatar
    Join Date
    Jul 2016
    Location
    Westfield, IN
    Posts
    137
    Quote Originally Posted by Bill@HPTuners View Post
    1. firmware is updated automatically via the editor/scanner software whenever the software sees you are using old firmware on your interface, no additional downloads necessary.
    2. 4.6.3 is the newest public software
    3. no there is nothing you need to do, VCM Suite infolog will tell you what firmware version you are running on your interface.
    4. if you are having connection issues the easiest and cheapest test is to replace the usb cable, if you are not having an connection issue you likely don't have a hardware issue.
    Well, I was able to fix the trans P0606 issue from this; https://forum.hptuners.com/showthrea...451#post607451
    However, now my PID for Trans shift mode reads "unknown: 80" Haven't figure that out short of removing and re adding possibly.
    __________________________________________________ __________________________________________________ __________________________________________________

    "To explain the lure of speed you would have to explain human nature; but it is easier understood than explained...Speed is the second oldest animal craving in our nature..." -- T. E. Lawrence
    2000 Regal GSE
    2007 Trailblazer SS

  20. #20
    Potential Tuner
    Join Date
    Jan 2016
    Posts
    2
    I have a mpvi pro that was working great yesterday. Updated to latest software from 3.4 and now a tune that ran fine yesterday won't start. Reads and writes the car fine but file is fucked. Commanding .29 eq ratio while cranking where same file yesterday commanded .8.