Results 1 to 4 of 4

Thread: new build, looking for some advice on tune

  1. #1
    Potential Tuner
    Join Date
    Feb 2020
    Posts
    2

    new build, looking for some advice on tune

    Hi everyone, I've been building engines for awhile but new to tuning. This motor is in a 68 camaro with a t56 magnum. I started and it seems to idle ok, but the LTFT seems very high at around 30. Any recommendations would be great. I also plan on getting a wideband in the near future.

    LS3 block 416 cu in
    11.4 compression
    232/242 .621"/.604" 114+4
    LS3 heads, injectors and intake
    1 7/8 headers with 3" exhaust
    Attached Files Attached Files

  2. #2
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    9,809
    What's your fuel pressure?

    If that is okay then I suppose you could just add 10% worth of the fuel to the MAF and VVE tables to see if that brings the trims down from +30.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

  3. #3
    Potential Tuner
    Join Date
    Feb 2020
    Posts
    2
    According to the scanner it?s at 58 psi

  4. #4
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    9,809
    That scanner pid won't be right because you don't have the fuel pump control module that would have come on the stock vehicle you got the engine/computer from. I also doubt you are running a fuel pressure sensor in the fuel feed line. There is no sensor at the rail or anything like that.

    Manually check fuel pressure to make sure it is around 58psi.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.