Results 1 to 7 of 7

Thread: FG6 Turbo timing / boost compensation / Idle in park netural lean

  1. #1

    FG6 Turbo timing / boost compensation / Idle in park netural lean

    Hey guys,

    Just getting my head around some tuning of my FG turbo and have a few questions with small issues im running into.

    1/ AFR's are a little rich on full boost (approx 11:1 @ 16psi) but pretty good otherwise cruising
    2/ AFR's great at idle in drive but netural and park sees AFRs shoot up to 17:1 and stumbles
    3/ Logging I find that as soon as I hit 6-7psi boost timing falls away and I cant change it. Is there a boost compensation table or is this torque management that's doing this as my spark table commands much more timing.


    Only mods are 1000cc bosch injectors, bigger fuel pump with 4mm hole drilled in bottom pipe as recommended and battery re location with big air pod in box and removed cat converter. I know the high and low fuel rates are just rough but I experimented till I got some great idle and smooth running as well as good, if not a little rich AFRs through rev range and boost curve

    Any advice would be great thanks
    Attached Files Attached Files
    Last edited by Horsepower Zone; 2 Weeks Ago at 06:04 AM.

  2. #2
    Potential Tuner
    Join Date
    Dec 2019
    Posts
    3
    have you been adjusting MBT or BLK tables? the pcm uses the BLK timing table at wot. have you been watching your fuel trims? use forscan to check them at idle in park. if there out by 5% or more it will run abit funny as closed loop tries to catch the trims wich kind of sounds like your issue.

  3. #3
    Thanks heaps for such quick reply yoda,

    No, I haven't used the MBT table as I was under the impression the BLK was just the theoretical timing and didn't make a difference to the base table (though did seem odd if that were the case why could I change the values though I did notice those tables more matched what I was seeing while logging)

    Where is the BLK table located, I couldn't see it?

    I use tech edge wide band and the AFR's are definitely more than 5% out. In drive they seem fine at idle, its just in park/neutral they lean out massively. What mods can I do to the closed loop to try and fix this as it seems weird why it would do this now and not before when had stock injectors in it and there wasn't a problem. Im a believer that since ill I did was put larger injectors in and adjusted the high and low fuel flow rate and the rest is basically standard then if I get those high and low figures right it should behave again like a standard motor. Since none of the closed/open loop stuff was modified it seems odd that drive AFRs are great but P/N are now way off. I started to wonder about the high and low fuel flow cut in and out and maybe my figures are causing it, either that or the pule width or breakpoint.

  4. #4
    Potential Tuner
    Join Date
    Dec 2019
    Posts
    3
    always set min pulse to 0 while testing. use the BLK for your wot timing. alot of tuners set the cars up to have matching mbt and blk tables so it actually gets what your commanding. what fuel pump do you have and do you have a way to monitor your fuel pressure?

  5. #5
    Advanced Tuner
    Join Date
    Feb 2014
    Location
    Sydney
    Posts
    293
    There are a lot of changes when compared to a standard tune file particularly in the idle airflow probably causing your idle issues. I would suggest going back to the standard file settings changing the injector settings as per the injector data for your injectors and tune from there with as fewer changes as possible to achieve the required outcome.
    Log with HP tuners looking for active torque management and remove/reduce in the tune as required.
    Last edited by Yortt; 2 Weeks Ago at 05:31 PM.
    Tune with actual data not simulated data!.....Applied Road/track Tuning

  6. #6
    Sorry haven't been on here for a while. Thanks heaps for the replies guys. Ill go and do those things you suggested and get back to you both

  7. #7
    I cant remember the model the customer put in but its a much larger one. Haven't checked fuel pressure yet though nothing has changed for pressure reg so expect it to be 4 bar still (I know.. dont ever assume! )
    We are getting 10.5:1 AFR full noise 15psi so its rich right now but didn't want to mess with fuel tables till injector sizing was better. Idle after 15-20 seconds goes to 14.7 but that's just the closed loop kicking in. Itns when it first starts its a little rough and the idle needs to be 800rpm
    Last edited by Horsepower Zone; 2 Days Ago at 05:02 AM.