Results 1 to 8 of 8

Thread: Zo6 M7 shifting lag when trying to shift quickly

  1. #1
    Tuner in Training
    Join Date
    Sep 2016
    Posts
    23

    Zo6 M7 shifting lag when trying to shift quickly

    All,

    Any insight as to when I try to quickly shift the car through the gears there is a 1-3 second lag where the throttle acts like its closed even though the accelerator is to the floor? I plan on doing some 1/4 mile racing and this will kill my ET. Seems to be a torque management function GM has in there??? I just want to perform transitional lift and quick shifts like in my C6Z but this C7Z just won't let me....

  2. #2
    Advanced Tuner
    Join Date
    Dec 2015
    Location
    Miami,Fl.
    Posts
    260
    Quote Originally Posted by N/A Zo6 View Post
    All,

    Any insight as to when I try to quickly shift the car through the gears there is a 1-3 second lag where the throttle acts like its closed even though the accelerator is to the floor? I plan on doing some 1/4 mile racing and this will kill my ET. Seems to be a torque management function GM has in there??? I just want to perform transitional lift and quick shifts like in my C6Z but this C7Z just won't let me....
    Are you activating the no lift shift feature? Maybe you're shifting too close to redline.
    2019 C7 ZO6 M7.

  3. #3
    Tuner in Training
    Join Date
    Sep 2016
    Posts
    23
    Quote Originally Posted by HeavyChevy305 View Post
    Are you activating the no lift shift feature? Maybe you're shifting too close to redline.
    No, not using NLS and even tried shifting around 6300rpm and still did it. I have heard of guys experiencing this same issue just not sure what the solution is HPTUNER wise. Maybe deactivating the No lift shift feature by entering 250 mph vs the 31 mph stock setting.?

  4. #4
    Advanced Tuner
    Join Date
    May 2003
    Location
    South Florida
    Posts
    589
    Does it do it when you have traction control turned off or if the car is in Sport 1, Sport 2 or Race?
    I've tuned a few things...

  5. #5
    Tuner in Training
    Join Date
    Sep 2016
    Posts
    23
    Quote Originally Posted by TriPinTaZ View Post
    Does it do it when you have traction control turned off or if the car is in Sport 1, Sport 2 or Race?
    I tried it in Tour, sport and track. Does it in all (3) modes. I plan on taking it out today and logging a 2-3 hard shift and see whats going on. I'm guess virtual torque settings but not sure. I am new to the C7 platform I am used to the C6 stuff.

  6. #6
    Advanced Tuner
    Join Date
    May 2003
    Location
    South Florida
    Posts
    589
    None of those modes are Competition Mode with Sport 1, Sport 2 or Race. Meaning traction control is set to its most aggressive and will pull the throttle on hard shifts. Hitting the rev limiter after pushing in the clutch because you didn't come off the gas fast enough will feel the same way since there is a Histories RPM value in the OEM tune.

    You can either press the traction control button once to disable and then test hard shifts. Or you can try Competition Mode and set to Sport 1 or Sport 2. Race mode will fully disable the traction control. If this solves your problem then you are running into a traction control limit. If this does not solve your problem then you are hitting the rev limit without realizing.
    I've tuned a few things...

  7. #7
    Senior Tuner SultanHassanMasTuning's Avatar
    Join Date
    Nov 2009
    Location
    All Around
    Posts
    2,534
    i have seen this happen when you activate the rev match feature
    E-tuning/remote Tuning Sultan@mastuning.net Follow @MASTUNING Contact/Whatsapp +966555366161

  8. #8
    Advanced Tuner
    Join Date
    Dec 2015
    Location
    Miami,Fl.
    Posts
    260
    Activate NLS and hold down the traction control button for 5/10 seconds. That's what I do and have no issues. Hold on tight though if you're on stock tires.
    2019 C7 ZO6 M7.