Results 1 to 15 of 15

Thread: 2007 pontiac grand prix 3.8 vats delete help

  1. #1

    2007 pontiac grand prix 3.8 vats delete help

    I have a 2007 pontiac grand prix 3.8 v6
    Have mpvi2 and need to delete vats badly. Im supposed to move and can't start my car. I did the turn vats off option but car struggles to try to start and when it does its like rough like in limp mode or something and isnt turning on fans. Please help me out.

  2. #2
    Anything ?

  3. #3
    Advanced Tuner TheMechanic's Avatar
    Join Date
    Jan 2014
    Location
    SoCal
    Posts
    744
    VAT's issue will be a flat out no start. Some early will start run for a second and act like the ignition was shut off. If it runs at all no matter how bad you don't have a VAT's issue.

  4. #4
    Advanced Tuner TheMechanic's Avatar
    Join Date
    Jan 2014
    Location
    SoCal
    Posts
    744
    Try this. Ignition off. Disconnect MAF. Key on Engine off for 10 seconds. start car. If it is good you have a MAF issue. Software/wiring/ECM/PCM/false air etc etc.

  5. #5
    This didnt seem to work. It cranks. Then idles for a few seconds then dies

  6. #6
    Im not sure how to attach my tune file to this post
    Attached Files Attached Files
    Last edited by Chadmoore88s@Yahoo.com; 01-21-2021 at 01:57 PM.

  7. #7
    Got it

  8. #8
    Advanced Tuner
    Join Date
    Sep 2010
    Location
    FL
    Posts
    373
    You have to figure out if it stalls because it runs like crap, or because VATS shut it off. If it stalls because it runs bad, you shouldn't have a security light. And if it stalls because of VATS, it should run just fine until it stalls.

  9. #9
    The car runs good if vats isnt involved i know.

  10. #10
    Advanced Tuner
    Join Date
    Sep 2010
    Location
    FL
    Posts
    373
    Did you get your car to run? If not, I can delete VATS for you.

  11. #11
    No, when i tried flashing with vats selected to off, it would turn over actually, but would either run really badly(limp mode/no fans etc) or not start period. So now i have it at a mechanic shop and they are having trouble with it also. The anti theft module made for these cars is just a piece of garbage and so is that whole system. Iv spent at least 1200$ because of it and still not running..

  12. #12
    It would run and stall quickly

  13. #13
    Advanced Tuner
    Join Date
    Sep 2010
    Location
    FL
    Posts
    373
    Quote Originally Posted by Chadmoore88s@Yahoo.com View Post
    It would run and stall quickly
    I've done 2007 Grand Prix PCMs before successfully. If you want to give it a shot, contact me.

    Steve

  14. #14
    Potential Tuner
    Join Date
    Feb 2019
    Posts
    3
    Quote Originally Posted by pontisteve View Post
    I've done 2007 Grand Prix PCMs before successfully. If you want to give it a shot, contact me.

    Steve
    I've got a similar vats issue on a 2007 grand prix based engine swap it runs for a few seconds then it kills injector pulse and won't restart till the battery is disconnected for 5 minutes
    I'd appreciate any help you can provide

  15. #15
    Advanced Tuner
    Join Date
    Sep 2010
    Location
    FL
    Posts
    373
    Quote Originally Posted by Joedirt View Post
    I've got a similar vats issue on a 2007 grand prix based engine swap it runs for a few seconds then it kills injector pulse and won't restart till the battery is disconnected for 5 minutes
    I'd appreciate any help you can provide
    Having spark, but no injector pulse, is because of VATS. Also, VATS typically lets a car start, run for about 2 seconds, and die. Over and over again. Plus, some sort of security light should come on. Further proof it's VATS.

    HPT's software doesn't work right for this in my experience, so don't waste credits.

    I can do it using different software if you want. Email me.