Results 1 to 2 of 2

Thread: Detect Protocol Failure

  1. #1
    Potential Tuner
    Join Date
    Aug 2021
    Posts
    4

    Detect Protocol Failure

    So the mpvi2 detect protocol failure strikes again. I have searched and read through most of post but they either get left without updates from OP or are applying to older cars.

    So my story, I have a 2016 Audi S8+, on Aug 20th I was able to connect and read my TCU. Debated back and forth if I wanted to tune and then this past week I said let's do it. Trying to connect I get the detect protocol failure. Device has been resynced multiple times (how I got the credits to show), I've tried the stable versions beta and Uninstaller everything and reinstalled.

    I ran a full scan on car with obdeleven found a code for the energy management system and ended up replacing and coding a new battery to my car. Drove around a bit scanned codes again and there is nothing left error wise from obd. (About 200 miles put on car)

    Hptuners unfortunately still does not communicate with my car.

    Other info:
    wifi has great connection at car 150/100mbps
    Support with hptuners was engaged but they are stumped and have escalated issue to engineering
    The device has successfully read my wife's 2019 chevy equinox (tested to see if device was at fault)

    Any other ideas to check for possible communications issues that I am over looking?

  2. #2
    Potential Tuner
    Join Date
    Aug 2021
    Posts
    4
    Hpt support came back that I need to have dealer recover my tcm. Does that even make sense since car still runs and drives and has never been tuned?