Results 1 to 4 of 4

Thread: 6L80E Clutch Pack Failure

  1. #1
    Potential Tuner BIGMAC's Avatar
    Join Date
    May 2022
    Posts
    3

    6L80E Clutch Pack Failure

    I recently experienced clutch pack failure in newly built race-spec 6L80E after only 6 dragstrip passes. My transmission builder thinks there may be an issue with the Engine tuning parameters and asked to see the ECM tune from my tuner. My tuner is hesitant to release the ECM tune to the trans guy. It apparently has to do with "Delivered Engine Torque" being less than the actual torque.
    Can someone explain this issue and what PID's to check on the VM Scanner?
    Thanks in advance.

  2. #2
    Advanced Tuner
    Join Date
    Jul 2020
    Location
    VIC Australia
    Posts
    515
    The engine torque tells the trans how much line pressure to apply. E.g. you're making 1050Nm on the dyno but engine torque PID shows only 500Nm, the line pressure will be way to low and the trans will burn out in no time.
    Trans Engine Torque is what I would log. Ideally what you want to see is dyno rwNm + 130Nm at a minimum. It doesn't have to be spot on accurate.

  3. #3
    Senior Tuner Ben Charles's Avatar
    Join Date
    Aug 2009
    Location
    Calibrating
    Posts
    3,058
    If it burnt up that fast I’m going to say it’s in the build… I’ve seen a lot of bad trans tunes over the years and even those seem to last awhile

    Email Tunes, Bencharles_10@hotmail.com
    96 TA Blown/Stroked, 4L80E/Fab 9
    15 C7 A8 H/C 2.3 Blower/PI
    14 Gen 5 Viper
    Custom Mid Engine chassis, AKA GalBen C

  4. #4
    Tuning Addict 5FDP's Avatar
    Join Date
    May 2012
    Location
    Rogers, MN
    Posts
    12,545
    If you're the guy paying both of these people, I see no reason why he should be hesitant to show the tune. It's your money that is being spent here.
    2016 Silverado CCSB 5.3/6L80e, not as slow but still heavy.

    If you don't post your tune and logs when you have questions you aren't helping yourself.