Results 1 to 8 of 8

Thread: Injector duty drop issue

  1. #1
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38

    Injector duty drop issue

    Hello, can anyone point me in the right direction as to why my injector duty cycle just dropped like crazy around 5k rpm? It only started once I upgraded to a 20G turbo.

    I had the stock fuel pump and it did the same thing so I swapped it to a AEM 340lp. I had 550cc injectors and swapped them to 750cc and it is doing the same thing with the upgrades. I swapped coils and plugs and the same thing. Oem coils and ngk plugs.
    Attached Images Attached Images
    Attached Files Attached Files
    • File Type: hpt 7.hpt (618.3 KB, 6 views)
    • File Type: hpl 7.hpl (305.5 KB, 7 views)
    Last edited by CaliberGuy05; 2 Weeks Ago at 05:14 PM.

  2. #2
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38
    New motor in and doing the same thing.. anyone got any input? i am starting to think its the injectors overloading?

  3. #3
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38
    Well i finally got a good pull in. Maybe if i would have noticed it better before i could have saved the old motor...

    To much fuel was dropping putting spark out as you can see in my hpl file.

    I need to figure out how to control spark better... I have changed alot on this car but I have not figured out how to control spark yet in the areas that i want it done at. Still pushing forward! good luck to anyone else around with the same issues and keep pushing.

  4. #4
    I seen this before.. if you need a remote tune lemme know

  5. #5
    quick fix.. turn off any FUEL SHUT OFF SETTINGS.. disable in your tq managment to start

  6. #6
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38
    Quote Originally Posted by luciddeath View Post
    quick fix.. turn off any FUEL SHUT OFF SETTINGS.. disable in your tq managment to start
    *update*
    I have tried this but no difference. I just changed to the Caliber srt 4 injectors and now spark seems to be back in the negatives again. I will be trying to sort that out. Also I looked a one of my previous tunes with my old motor and spark was fine and it did the same thing so that is confusing.

    Now i am trying to get idle and part throttle under control. as i am getting a cel for high idle.
    Attached Files Attached Files

  7. #7
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38
    I am interested because i am over this lol

  8. #8
    Tuner in Training
    Join Date
    Dec 2021
    Posts
    38
    Quote Originally Posted by luciddeath View Post
    quick fix.. turn off any FUEL SHUT OFF SETTINGS.. disable in your tq managment to start
    I am interested because i am over this lol