Results 1 to 5 of 5

Thread: RTD+ initial setup fails Firmware updatea

  1. #1
    Potential Tuner
    Join Date
    Aug 2022
    Posts
    1

    RTD+ initial setup fails Firmware updatea

    Just got a new RTD+. Using the TDN iOS app via my iPhone 13 Pro. During initial setup, it connects to Bluetooth and gets as far as wanting to update firmware. That fails multiple times. I then downloaded the RTD Flasher app to my Windows 10pc, downloaded the lates MPVI2 drivers and hit the "resync interface" button in that PC app. Now it tells me it can't connect to the RTD+ in the TDN iOS app. 2004 Ford Excursion - Key on, engine off.
    https://share.icloud.com/photos/0d0S...URF3WVYrO12HQgSee the link to a screenshot video. Any ideas to get this rolling?

  2. #2
    Advanced Tuner veee8's Avatar
    Join Date
    Apr 2006
    Location
    Raleigh, NC
    Posts
    449
    Quote Originally Posted by XJGB412 View Post
    Just got a new RTD+. Using the TDN iOS app via my iPhone 13 Pro. During initial setup, it connects to Bluetooth and gets as far as wanting to update firmware. That fails multiple times. I then downloaded the RTD Flasher app to my Windows 10pc, downloaded the lates MPVI2 drivers and hit the "resync interface" button in that PC app. Now it tells me it can't connect to the RTD+ in the TDN iOS app. 2004 Ford Excursion - Key on, engine off.
    https://share.icloud.com/photos/0d0S...URF3WVYrO12HQgSee the link to a screenshot video. Any ideas to get this rolling?
    What IOS version are you using?
    www.crawford-racing.com
    Home of the original and best selling CR-Fueler plug and play port injection controller kits for all GM Gen V direct injection platforms.

  3. #3
    Potential Tuner
    Join Date
    Nov 2020
    Posts
    1
    Did you ever figure this out? Based on the video you posted, I don't see an attempt to "forget" the RTD from bluetooth settings and retry the setup process for it. That would be worth a try.

    Also, what iOS version is your phone on?

  4. #4
    Quote Originally Posted by brutus View Post
    Did you ever figure this out? Based on the video you posted, I don't see an attempt to "forget" the RTD from Bluetooth settings and retry the setup process for it. That would be worth a try.

    Also, what iOS version is your phone on?

    I'm on Android and using a brand new MPVI3 and I tried that (unpairing the device in the BT settings). Didn't work out too well for me. Now, I try to go through the first time setup and it fails immediately with a "Blutooth discovery error!"
    Almost like the app isn't even trying to connect, the error comes up so fast. I've opened a ticket on another issue, so I will add this to the other one.

    Good luck to the OP. Let us know if you figure anything out.

  5. #5
    Potential Tuner
    Join Date
    Oct 2022
    Posts
    2
    I have the same issue. I cant do anything with my iPhone 12 with 16.0.2.

    I know TDM have an issue with iOS 16. Looks like is resolved with the las uptade of TDN app. However in my case still with the issue.

    I try with my old ipad mini 2 with iOS 15.7 and works better. Some issues like the log cant be shares and stock cant be uploaded.
    Support tkt created. I hope they resolve the issue soon.